Am having sharing permissions with my project

Hi there, this problem still persists. I am encountering this with my form with only 9 users (including me, the owner).

I am trying to apply new permissions to a user of a form that I created. I want them to be able to edit submissions. However, every time I try to do this it has an error message “Failed to update permissions”.

I then tried deleting the user and then re-adding them. This is again met with the error message “Failed to update permissions” even if I select all permissions they had before I tried to add ‘edit submissions’.

Their username starts with an “h” so not relevant to the ‘solution’ above where users were required to change their usernames due to a bug.

I also tried disabling the public link sharing as was also noted as a solution however that has not helped resolve the situation.

If you could help me resolve this issue that would be greatly appreciated!

Welcome to the community, @dominicthomson. Would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

@dominicthomson, please be informed that this was an issue at our end, which has now been resolved. The sharing permissions should now work smoothly. Thank you once again for bringing this issue to our attention!