Can not add questions to library for reusing in other projects

Hi colleagues,
Recently, I observed that I am not able to add questions from the existing forms to the library to use them in some other projects. Any feedback? :slight_smile:

Would you also let us know the server you are using?

Hi, I am using humanitarian server. However, i tried both the server - both do not allow me and neither I receive an error message.

I have not yet found a solution to this issue. Any update on this?

I tried adding question to the library and i could. Could you explain me the process you tried to add question to the library (where you were not able to)? Did you try uploading questions to your library from an xlsform or adding them through the form builder UI?

What i tried to do is that when i create a question using UI, after a question having options is created, since i use that question in my other projects as well so i click the button “add to library”, but it seems that the button does not work at all - i should tell you that i used to use this function before without any issue but this is a new issue.

Hi @danishjownaqibullah
I can confirm that this issue does not exist on my side, just as @Kal_Lam had checked on his end. I would suggest you try refreshing your browser and/or changing it and see if the problem persists.


1 Like

Hi @stephanealoo,
Although today i even tried another browser thinking that it might be issue with chrome but still no good luck. I will try using another account or my account using another computer, and will see if it works and update you accordingly.

hi @stephanealoo, @Kal_Lam,
I just tried different options including, I created a new test project in which I was able to add questions to the library.
However, I used another browser and even another computer to add questions of the projects that were created months ago and have once been archived, after unarchiving, I am still not able to add questions of those projects to the library.

@danishjownaqibullah, could you provide a screenshot of the same and also provide us the following information through a private message. Maybe looking closer to your issue would be helpful to see what is happening with that particular survey project.

Please provide us the following information through a private message so that we could have a closer look at your case:

  • Username
  • Project name
  • Server

Thank you, I replied through a private message.

Thank you.

Thank you @danishjownaqibullah, i have created a GitHub issue for the same. You could follow it here:

Thank you, and I will be following the issue on the GitHub page.

1 Like

Thanks for posting the issue of “Add questions from inside a group to library” on gethub forum. I just wanted to know how long it will take to solve the issue and how i will get informed? or may be the issue will be resolved in the next version release of Kobo?
Thank you in advance

1 Like

@danishjownaqibullah don’t know exactly how long as it depends upon the developers time and priority. However will notify you when the bug is fixed.

Thank you. Appreciate it.

1 Like

As I checked the system today, the issue has been resolved by the developers, now we can add questions to the library from inside or outside of a group to the library.