Data submissions from Kobo doesnt reach to the forms we have

Data is not going through to the web inspite of using the correct form. We have been using the form for some time but discovered that data can’t go through since the previous two weeks. Please assist

Hi Otioz,

Am also facing the same situation with 2 of my projects where the data isn’t reflecting or data is missing/blank in my downloaded data.

Hoping to get a solution from the community as well on retrieving my data and what the issue may be to avoid it recurring.


Did you at any time update the collect questionnaire? Your form id may have changed.

Hi Reverton,

On my end I didn’t update the collect qnr.


I did not update the form. We have even tried following through from the questionnaire to the kobo collect forms and tried to submit personally from our staff side but still nothing. Its the same form and questionaire. Is it possible for a form ID to change without updating. And even if it does we should be having data of the old form. It doesnt give a warning that the form does not exist

Hi @otioz, @PaulN

Have you gone through the support article:

These support article should help sort out your issue!


Hi @ Kal_Lam,

Yes, I had gone through the articles shared but still didn’t resolve the issue(s).