Delete form histories

Hello KoBo community, I have upload and deploy my excel form to KOBO many times, So I wish to delete the form histories that have uploaded, because I cannot generate report and show the default report page. Could you tell me how to delete the previous version, and keep only the active version?

Welcome to the community @chamnabchhoeung! Form histories should not affect your custom report. Could you share with us a screenshot of the issue you are having with your custom report. Maybe the community could help you out if there is anything there.

Hello @Kal_Lam
Here is the issue from my point. I think because I have upload many version with different questions (added) then the report page not show.

Could you let us know the server you are using?

I used kobo.humanitarianresponse.info

Could you share with us your xlsform? Maybe we could try making a dummy entry and see if the same happens at our end?

I could share, but when I uploaded and deployed it as a new project with the version 1, it can show the report page as normally. So I think it is no problem with the xlsform. I think it problem because of many version that I have updated. Honestly, I don’t want to delete the current project by replace with new upload for the new project because it impacts to my current peer staff who ready use the link for data collection. So could you have another idea to help me?

Can’t exactly say what has caused you this issue. Maybe we would be able to troubleshoot if you share with us the following through a private message:

  • Username
  • Project name
  • Server

@chamnabchhoeung, after taking a closer look to your xlsform I could observe that there are some issues with your xlsform. One I found was a duplicate of choice names (which generally should be unique).

image

Try validating your xlsform with this online validator. It should identify you the syntax issues that is present within the xlsform.

Thanks you for this catch up the error, and now I have updated it accordingly.
However, the report page is still show error. How can I fix it?

First you will have to ensure that your xlsform is syntax free.

I used the link you share, and I check it out, the result is valid with my form.
image

If so, could you share with me your clean xlsform through a private message? I would like to have a look at it.

Your xlsform seems clean now. Would you mind uploading as a new project and see if you are able to upload some submissions and see the submissions in the custom report?

Like what I have mention, to upload as new project, the report is fine to show the result as I test it many time. But I don’t need new project, I need to fix my current system (project) that all of my staff used it. So I don’t want to change the link to them because concern of confuse.

So may I assume that there is no solution to fix my current project at least upload to new project as only one solution for this. Am I right?

Have flagged this to our developers and will let you know when the fix is done. But kindly please be informed that it may take some time (until the fix to happen)

What is the link using for?

@chamnabchhoeung, kindly please be informed that your issue has been solved.