Dynamic data attachments post-Sept 1, 2023

Dear @Kal_Lam ,

I am using the US server. On August 30, 2023, I successfully created linked parent-child forms in which the child form was able to call data entered into the parent form. On Sept 5th and 6, 2023, I entered new parent data. But, without changing the XLSForm or anything else in either project, the child form was only able to call data from the August 30 entry, not from the data entered on either Sept 5th or 6th. The issue is still ongoing.

I do not believe this is an issue with the EU server switch, as I am on the US server. But I wanted to check if there may be any other reason for this to stop working between Aug-Sept, or if there is a new lag in the connections between parent and child forms.

Any help is much appreciated. Thanks so much for managing this great platform!


@DanielJohnRead, have you tried checking out the XLSForm from the support article to see if this has any issues?

I hope Sept 1, 2023, should have no issues with the Global Server as Sept 1, 2023, is only related to the EU server (formally known as the OCHA server).

Hi @Kal_Lam. Thanks for your prompt response.

Yes, I had based my forms on the XLSForm from the support article. Like I said, everything works perfectly for the first entry in the parent form (entered August 30, 2023). I can call all data I need from that entry to the child form. However, the child form does not access any data from the subsequent entries to the parent form (entered after Sept 1, 2023).

Can you think of any coding reasons why this may happen? Is there some filter I missed? I’ve attached my XLSForms here in case it’s useful. Let me know if you have any questions.

Thanks for your help,

Child_form-DR.xlsx (11.2 KB)
Parent_form-DR.xlsx (18.9 KB)

Hi @Kal_Lam ,

It appears that the issue has been fixed. I tried entering data into my child form yesterday (Sept 13) and Enketo asked me to refresh the page to update to a new version. After doing so, the child form works perfectly. Thus, it seems it was a behind-the-scenes fix that has now been resolved.

Thanks very much!