Error: Binding path not allowed


I am struggling with a form I developed and deployed previously which is working in a project on KoboToolbox.

I made some changes and redeployed the form and now i am getting the error:
‘Binding path [null] not allowed with parent binding of…’

I went back to the original form (before the changes) and created a new project and deployed the form and have the same error.

I went back and downloaded the working version of the form on the server to a new tablet and it is still working without any errors.

I then went to this project and downloaded the form as an .xls document from the server and tried to upload it as a new project but receive the same error even without any changes.

I am not sure where to begin looking for the error as the form comes up without errors on and there is a working instance of it in another project.

Any ideas of where to start looking?


Hi @Rusti,

From your post i see that the previous version which you uploaded does not have any error. The error started popping up once you made updates. Please be informed that such types of errors are generally seen when you make an unseen mistake in the XLS forms.

If you are still not able to find the error through the XLS form error finder (the link you shared), please share your XLS forms with us so that we could help identify your issue.

Hi Kal,

Thanks for the reply and i hope you can assist as i can find the error. As mentioned i have tried to reload the xlsform prior to any changes and it is still giving the error, but the version i originally deployed is still working and collecting data.

I have attached a shortened version of the form where the error is occurring (if i cut this section out of the original it works). XXX in the form refers to an earlier calculated field which is not in the current form.

Thanks and hope to hear back, Regards, Russell

I don’t seem to be able to upload an attachment as i am a new user, any way around this?

Hello Rusti and Kal,

I’m having the same problem, and it even hapens when I clone an old project that was working previously, so maybe the error is not when I upload the XLS.

I also tried what Rusti mentioned, uploading the same XLS of an old (working) project and the error popped up again…

Funny thing is that in one of my devices the form is working normally (Samsung J7 Prime, KoboCollect v1.14.0a), while in all other devices (mostly Samsung T110N tablets, also running KoboCollect v1.14.0a) I get the binding path error mentioned. All the settings are the same in both devices and I have no idea what is going on.

Hope that it is not something too complicated, and if there is another test that I can help with to narrow the problem down, please let me know!


P.S. This tool is awesome and helped me a lot already, thank you guys for the amazing work done here!

Hi @Rusti & @ejsk,

You must now be able to upload the XLS file (seen at the top) in the compose message box. Kindly please share so that we could be able to figure out the problems.

Hi Thanks, please see the shortened xlsform attached now.

nested repeat.xlsx (30.5 KB)

Hi @Rusti,

I went through your XLS Forms and saw it very impressively built. The problem i noticed here is the use of the nested begin repeat. Seems that the begin repeat does not work under the begin repeat (i.e. in the nested form). I simply removed it and it seems working now. Kindly please see the attached file for your reference!

nested_repeat.xlsx (26.5 KB)

Thank you for you input, but you have removed the second part of the question about the length of the fish. I need the form to ask how many fish were caught of a particular species and then allow the data capturer to enter the lengths of the fish based on the answer under number caught. That is why i used a nested repeat so i could get number, weight and lengths for each species under one repeat. I am nit sure why it stopped working as it used to work fine.

Hi @Rusti,

I would suggest you to use one begin repeat/ end repeat instead of nesting the begin repeat/ end repeat.

Seeing your concern, i would suggest you to create your form in the following:

  • Have any fish been caught today?
  • If yes, how much?
  • Now start with begin repeat (simultaneously use repeat_count (to control the number of fishes caught here)
  • Then list out the questions for each fish caught i.e. species, weight etc. You will have to respond to the list of repeat questions till it matches the number fish caught.
  • Use the end repeat now

Maybe keeping it in this simple format would help you collect all the required details of the fish.

Thanks again for the feedback.

However, I need the first repeat to select each species, and then the lengths within each species. The enumerator then needs to be able to select the next species as the main repeat.

The data i need is

Species 1
number e.g.3
Length1 (based on above number)

Species 2
number e.g.5
Length1 (based on above number)


This is why i initially used the nested repeat with a repeat count using the number.

It was working perfectly and now I cannot get it to run on a tablet. The version I initially uploaded to a project is still working, I just cannot get any revisions (or old forms reloaded) to work.

It is very confusing.


I have attached an alternative work around which works but the data comes out in a bad format for importing into a database. The lengths come out in separate columns rather than in a list in one column. It can work it just means more formating before importing.

I am still very curiousAlternative to nested repeat.xlsx (30.7 KB)
as to why the previous form with nested repeat has stopped working…

Probably you are trying to collect data with KoBoCollect. But to run your form you have to use updated ODK collect. KoBoCollect is a copy of ODK collect but not updated copy of ODK collect. Could you please install the ODK collect in the device along with KoboCollect and use ODK collect as default and send data to your Kobo server.

Wow, Thank you very much, after spending much time on this, a simple switch to ODK has resolved the issue and the nested form repeat is working again.

I assume if i put my Kobo server details in it will connect and send data to Kobo as per Kobo Collect.

Any developers who can update Kobo Collect as i have my enumerators running Kobo in the field and i am not going back to see them for some time.

Thanks very much for the advice on this.

Thank you @azadkhan for this advice, I used this approach. The forms appear in the kobocollect server but when I download the data I can’t see the data. Kindly advice.