Error when editing completed surveys

Hi there,

We had a data collector accidentally select the wrong village name for a handful of surveys that have been finalized and sent to the server. I am trying to edit them to simply change the village name selected on one of the survey questions. When I make the change and then save the form, I am presented with an error that says “Submission Failed - Data server did not accept data. Contact the survey administrator please. (400)”. Can someone please help me fix this so I can change the surveys to the correct village? Thank you!

@amaglior, would you mind trying this workaround that has been discussed previously?

Hi there,

I tried the workaround as described (including logging out through the 2 links provided and opening a new incognito window) and still receive the same error message when trying to edit completed surveys.

One thing that could be a culprit: it’s only a selection of surveys that are giving me the error when I try to edit them. What happened was one data collector accidentally listed the wrong village for 29 surveys. So I went in and tried to edit the village listed by the “bulk edit” function. But I messed it up as it was not very straightforward and the result was not editing the surveys but duplicating the 29 surveys (so I retained the 29 original and then also had 29 duplicates with the edit that I made (which actually was an incorrect edit on my part)). So I deleted those duplicates and am now still just left with the original 29 surveys with the incorrect village. If I try to edit other surveys for other reasons that aren’t one of these 29 surveys, the editing process works perfectly. So I’m wondering if these 29 surveys got messed up somehow when I tried to bulk edit? But from everything I can tell, the data is still there, they appear in the data downloads, etc.

Any other help? I am really hoping to change the village on these 29 surveys. Thanks.


@Kal_Lam or anyone else from Kobo Core Team, any further thoughts on this? I’m really struggling with not being able to edit the submitted data while it’s coming in.


@Kal_Lam Also I’ve tried the bulk edit function, and it appears to be glitching…it is duplicating all the surveys I’ve edited instead of just replace the one question with my desired change. Kind of a mess!

@amaglior, we have recently made a new release that should solve your issue. Could you kindly check it and let us know if you are now able to make edits and submit the data to the server?