Form replace issue

I downloaded some forms in the XLS version and made some changes. After that, I would like to replace the form with the edited one, but when I click replace form button, It is stuck in loading. I couldn’t find any solution. I am using the humanitarian server

I tried:
1- Waiting for a long time doesn’t work
2- Tried other Mozilla, Chrome, and IE didn’t work
3- I tried a different computer, didn’t work
4- I tried a different kobo account, didn’t work.

@osmanburcu, maybe validating your XLSForm through this online validator should give you some clue if there are some syntax issues within your XLSForm.

Hi Kal,

Unfortunatlly, it is not about the forms because i can upload the forms as new, and it is working perfectly, problem starts when i click the the replace button. I even can’t see the upload screen to upload my form.

Dear Kal,

I need to replace my forms, but I am stuck this way for two, or three weeks, and It is essential for me.

You can find a video of the problem Kobotoolbox Replace issue - YouTube.


As a workaround can you try clicking on the form, going to Form then clicking on replace form in that area?

I think this way works for now.

1 Like

@osmanburcu, feel free to reach us if you still have issues with form replacement!

1 Like

thank you Hakan,

this works as a workaround

1 Like