Issue when uploading xml submission

I am trying to upload xml submission file to https://{base_url}/api/v1/submissions endpoint. I am able to upload by using postman but when I tried with curl request, I am getting the error “Not Found”.
After testing several times, I found that I am able to upload the file using curl request with the credentials of the user who has created the form. But when I am using other users’ credentials who has the rights to upload the file but is not the owner, I am getting the error.

curl request : curl -X POST -F xml_submission_file=@/tmp/test.xml https://{base_url}/api/v1/submissions -u **** --header Accept: application/json

The error I get is this - "{“detail”:“Not found.”} "

Any help is appreciated. Thanks.

Have you tried with a user account who is not an owner but has Manage project as sharing permissions and see if it works for you?

Hi @Kal_Lam when I try to Grant Permissions, these are the options available, I can not see the permission - ‘Manage Project’, thanks.

Also the Kobo is installed in our own server, if it helps.

The Manage project is available in the publicly hosted server.

Can it be made available on Kobo on own server?