Loading error: Cannot read properties of undefined (reading 'media')

Hello there,

I was able to “view” all the submission records in Kobo until this morning, where I encountered the below loading error when clicking the “view” button for any submission, which says “Cannot read properties of undefined (reading ‘media’)”


Could you please advise what the issue is?

Thank you

1 Like

Welcome @lfacttgf ,
There has been the same posting here Having issue while I'm opening the view from the Submission Record.
Is this the same project/form? Let us avoid, please, posting the same issue twice for the same project.

1 Like

Hi there,

It’s two different projects, and I see that post has not been answered either. Would much appreciate your advice on how to resolve this issue, many thanks!

@lfacttgf, could you also let us know the KoboToolbox server and the browser you are using? This should help us troubleshoot your issue.

Dear Kal,

We are using the Non-Humanitarian Server, and have always been using Google Chrome as the browser and never had any issue until this morning. Thank you!

@lfacttgf, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:


I’m having the same exact error message when trying to view the submissions to a form. Is there any advice on how to solve this?


Hello @Kal_Lam,
As there are several similar postings in the last few months, there might be a more general issue, e.g. on parser level and it might be related to a system update.

Esp. it seems strange that error messages relating to GPS types pop-up for forms without any GPS element. (@Kal_Lam)

1 Like

@lfacttgf, I tried this on Windows 11 OS using the Chrome browser. FYR, I did not have any issues loading the form:

When clicking the eye-like open button:

When clicking the pen-like edit button:

As a workaround, could you try clearing your browser’s cache and updating it to its latest version to see how it behaves?

1 Like

I have the same problem, when loading the implemented form there is a “loading error” signal. I already deleted browsing data and cookies, it doesn’t work. Can someone help me, thanks.

Welcome to the community, @evaluacionfao_2022! Could you also share with the community a screenshot of your issue so that the community should also be able to help you solve it?

I am also having the exact same issue, as are multiple members of my team who work with our project forms. The error message is exactly the same as in the original post. We also use the non-humanitarian server and have only recently started experiencing this issue within the past day or so.

The site also seems to be generally taking longer to load, and we are experiencing crashes more frequently when trying to load forms, data, etc.

1 Like

@caratupps, could you check this out on a different PC and browser to see how it behaves?

Hello Kal,
Thank you - my Google Chrome is updated and just cleared the cache, the same issue persisted. We usually click the “view” button instead of “edit” as we do not make changes to the data received, currently as a workaround, the “edit” button seems to be working.

1 Like

Hi @Kal_Lam my team is having the same issue since sunday.

Username: xxxxxxx
Project name: Formato de Evaluación de Predio
Server: general use server

When we click on the View bottom:

We have the same error.

I try clearing the browser’s cache an updating it.

Thank you.

Has anyone been able to solve this problem yet?

Same issue here as @profservicios1

See, please: 'view' feature gives error - #11 by Josh

1 Like

hello everyone,
I have exactly the same issue

it doesn’t solve the issue

As you can see in the linked posting, the bug is in the hands of the development team now.

1 Like