Map views: disaggregate by survey responses returne "Not set"

Hi all,
I conduct a survey, the map view is find, it show all the location where the survey were conduct. However, on the bottom left, there is a option for disaggregate data by survey responses, some varaible work, but most of them don’t work it returned that "not set"
Can anyone suggest?


Many thanks in advance!

Hi @sengkrisna,

Please note that you will be able to disaggregated data through View By if your variables are categorical (having pre-coded data in the survey forms). However, you won’t be able to see them if they are in a different variable format i.e. continuous, text, date, time etc.

For your information, you won’t be able to View By categorical variables in the map even if they are precoded, if it’s a multiple response (select multiple format) question type.

That helpfull, let me check my variables and test.
Big thanks Kal Lam

1 Like

In tht case, would be possible to go back and change the vaiable to pre-code data? I dont see any option to edit the variable for the question already set up.

Please suggest
Many thanks in advance

Hi @sengkrisna, I assume pre-coded questions can be set only at the beginning of the survey and it can’t be changed later during the survey.

Dear Kal Lam,
I already test, for those quesiton that I already have it as single chioce and pre-coding from the begining still not work! I think the reason perhaps I made revise sereral time of the form and re-deploy many time? regardless it all pre-coding? eg. for marital stutus. I have married, divoice, separate and single ALL are pre-coding. then latter on I inlcuded option Don’t know (for some reason, the person interview can not tell the third person marital status thus don’t know option required there. ALL pre-coding, But just deploying and add differnce timeframe. What do you think? also for the option of gender, I do have it pre-coding option as Male and Female, But still it doesn’t work why? Would be great if you could give addditional suggestion

Hi @sengkrisna,

Have you tried plotting your map through the project (legacy)? Maybe you will have luck there?
After clicking the project (legacy) follow the following:

  • Select the project which has GPS coordinates
  • Click to GPS Points
  • Click on map

If it’s not working on your account even when using the project (legacy), the problem might be due to the multiple deployment during data collection. Could you so try viewing your map (using View By) with another dummy project to check if it works when you haven’t changed your pre-coded variables?

Dear Kal Lam,
The project legacy work! most of them, but some are not it just said" display option without data" I can observe that those vairable that I continue add option (even pre-code) and re-deploy it wont work. but those in the original pre-code is work.

I wish it could easily to edit on the form around coding and change type of quesiton (single, categorical, multiple, scale…etc)
Can it be able to reverse from excel? after we download, and we edit and upload back??? I never try that

Many thanks

Hi @sengkrisna,

Would advise you to create a dummy project and then test on it rather testing on the main project. As sometimes, testing on the main project could screw-up your entire database. If you are able to make changes on the dummy, you could then go on with the main project.

Hi !
I met the same issue. Even when I try @Kal_Lam’s solution in project (legacy) it still not working. Also try with different project to be sure…