Matrix questions are messing up my form

Hi, I’ve been working on a form using matrix questions with the “grid, various pages” mode selected in chrome (v. 73.0.3683.86).

Every time I deploy the form, a new “undefined language” is created (somehow, mysteriously) which ends ups messing up all the matrix questions that I had previously set up (names disappear and fields become “null”) and therefore preventing me to redeploy a new version of the form. I’ve tried deleting this new undefined language, changing its name, creating a new form from scratch and changing the language before deploying but nothing seems to work.

I’d really appreciate you checking on this bug since matrix questions make forms less tedious and long.


Hi catarami93

Is it possible for you to share xlsform file that questions ? Just the matrix questions.


Sure, I did one new form in order to be able to show you the whole thing.

Here’s a folder with pictures of what the app shows and the xls file.


Hi carami93

Please, find the attached file …
carami93.xls (28.5 KB)

Please note the changes highlighted in yellow …

Tulus Budianto

Thanks! It didn’t quite solved it, but allowed me to understand how to organize the form the way matrix questions do.

I also have just had this issue happen to me. The Matrix question seems to be an incredibly buggy question type. I am having several issues with it and is giving me a big headache as every time I save it it seems to do some weird reorganizing thing that requires me to go back and fix a whole load of things.