"object" error and data empty

I have a box that group different questions, in the page, the form shows the responses well, but the xls is empty in this set, besides, in the name of the box, the value appeared [Object, object] two or more times and in one of the question appeared the response same quantity of times that [object, Object] in the name of the set

“Generalidades” is the name of the questions set
“generalidades /consecutivo_emergencia” is the field that shows multiple values, must be just one
and the rest of the responses associated to “generalidades” in the xls is empty

Welcome to the community, @hoffmat! Please be informed that we have a GitHub issue for this which you should be able to follow here:

Thanks @Kal_Lam but reading, the issue was produced by a change between repeat_group and normal group. In ma case, I made “Editing Responses in Multiple Submissions” like the documentation: select a group of rows and change one or two columns.
After I opened the forms individually and saved them expecting a concatenated auto column to update. But once saved the form, in the kobo appear the column with the group’s name and the values [object,object] and the concatenated fields appear two or more times, and in the xls the gruop data dissapear.

I hope you can help me

Thank you for providing additional details @hoffmat. Just a query, did you also edit the repeat group questions, or did you simply edit questions other than the repeat group?

My form have a normal group with five elements and using two of this to create a concatenated value, i don’t have a repeat group in this form. The first value is a selected_one field and the second is a date. Is like:
Selected one: BC, AC, RP
date: 2022-01-02
calculated: BC_2022-01-02

  1. I edited a value in multiple submissions, speficically the field selected_one (BC, AC, or RP), this value changed fine but the calculated field not changed… if the original value was BC and I edited for AC, the calculated value continues with BC_2022-01-02,

  2. I opened the form, and saw if the calculated field changed, (I have a note that show me this calculated value) and yes, appear with the new value that I edited previously, so I just clicked submit.

  3. Updated the kobo site and in the table appear the new column with the same name that the group name and the value object, object

  4. I downloaded the xls and the values into de group dissapear, but in the kobo table appear

  5. I tried to edit the form openened and changing the values that “dissapear”, clicked in submit, and again the values appear in the kobo table but no in the xls.

  6. I tried to edit with multiple selection and the values appear like n/d, clicked in the edit, changed the value and save… doesnt work neither.

  7. I wrote you

I don’t know if edit fields outside group works or not


Thank you @hoffmat for describing the entire process in detail. We could also keep this as a backup to resolve the issue that has already been created in the GitHub.