Problem with putting question block into a form - empty answers

Hello! I’ve created a question block in my library with a single choice, multiple-choice and text questions. When I try to add this block to a from, it is added but all the answer options are empty (but the XML value shows up correctly). I’m not sure if there is any why do fix this? Is there an error in my block or the way I’m pasting the block into the form?

I made a quick test by importing a block of questions from the library (having choices for the questions like select_one and select_multiple) to a form builder and i was able to see the choice options with the appropriate code assigned.

Would you mind checking by following the instructions at your end:

  • Design a question block with select_one or select_multiple questions.
  • Ensure that the options for these questions has appropriate XML value like 1, 2 etc. instead of having AUTOMATIC.
  • Save the block.
  • Now build a form from scratch.
  • Pull the block to your form builder interface (from the library).
  • You should see the XML value that you had assigned previously.

Hi, thanks for the response. I don’t have “automatic” in the options, I checked. I think the issue is that I’m trying to include this block in an already deployed from and that’s why the answer options are not showing? I tried pulling to block to a brand new form like you suggested and it worked without an issue.
So for some reason with an already active from the answer options just say “Empty”. And XML value shows correctly, in my case “yes”, “no” for example.

1 Like