Problems in sending data to the server

Hello dear all, happy to find this community.
I have problems sending data to the server. Indeed, when I want to send the financialized questionnaire, I am told “Invalid URL”, while by this same URL I manage to download blank forms on my server.
Thank you

1 Like

Welcome to community @konanstephanenekoffi,

Can you tell which server are you using? Is it Humanitarian server, or the kf, or a private server?

1 Like

no, I use the non-humanitarian server

@konanstephanenekoffi, are you using the webform or the Collect android app to collect data for your project?

the Collect android app

@konanstephanenekoffi, could you also share with the community the screenshot of the error message you see? That should be helpful for the community to help you out.

you can find attached the capture of the message of the failure send failure and the server parameter

Great! Could you also share with the community the screenshot of the saved form that does not get synced with the server? That too should be helpful.

OK, the next step you have to do here is that check your server to see if you have this survey project deployed through your user account. I am sure your server does not have this survey form.

ok, i’ll see and get back to you

1 Like

you can see (in red) that the form is deployed from my server. But it still doesn’t work

OK, i see that you deployed it recently:

When I checked it previously I did not see the same survey project:


The thing that you have to note here is that once you deploy the project you will need to get the blank form to your app and then start collecting your data. You can then submit the submissions to the server. If you collect your data first and then deploy the survey project to the server and then try to submit your data to the server you will fail.

Effectivement, quand vous m’avez demandé de vérifier si le formulaire est déployé sur le serveur, je me suis rendu qu’il n’y était pas. Raison pour laquelle je l’ai déployé avant remplir un nouveau formulaire comme vous l’avez si bien dit. Mais, le même message d’erreur s’affiche toujours .
Indeed, when you asked me to check if the form is deployed on the server, I realized that it was not there. Reason why I deployed it before filling out a new form as you said so well. But, the same error message still appears.

You will need to do the following that this case:

  • Delete all the forms and submissions from your Collect android app.
  • Get a blank form (survey project) to your app.
  • Start collecting data.
  • Then save and submit it to the server.

There should be no issues now.

Dear expert, you are right. I just carefully applied what you said, and it works now;
Thank you very much for your availability, I am satisfied. have a great day :+1: :+1: :+1: :pray: :pray: :pray:

1 Like

Hi all, very happy to find this forum !

I have some finalized forms that refuse to send to the server, and the following error message pops up : Error : Generic Exception : Error (500) (see screenshot)

I am using the humanitarian server, and the collect android app to collect data
And the username is xxxxxxx

Thanks in advance for your help !

Welcome to the community, @julie_pi! Did you also go through this entire post? Maybe the discussion should also help you solve your issue.

Dear @Kal_Lam thanks a lot for your quick reply
I think that my situation is slightly different to the ones described above :

  • the survey has been deployed for over a year now in 10 different centers, and only a few are struggling to send in data
  • For those who are struggling, it concerns 10 or 15 forms out of 40 or 50 (on one tab with the Kobo Collect app), the other forms are sending in fine

Is there any other solution than the one you described above in the thread (which is deleting all the forms and submissions from the app and starting from scratch) ?

Thanks a lot for your time and your help

So you mean it’s an issue only for some of the users who are still able to send out the completed submissions (except for the 10 to 15 submissions which they are not able to submit) to the server?

Did I get you correctly?