Select multiple from external file issue on Enketo

I’m facing an issue in using select multiple from external file.
In detail, the form I built around 2 years ago includes, among others, three questions:

  1. Select one school from a list (through select_one)
  2. then, select one or more grades in the selected school (through select_multiple_from_file schools.csv)
  3. then, select one or more students in the selected grades (trough select_multiple_from_file students.csv), designed inside a repeat group (each grade - selected in step 2 – leads to a record in the repeat group, where the user can select the students).
    Recently I’ve found a weird issue, not there before: once users select the grades in the reverse order (e.g. from 6 to 5 and not from 5 to 6), the first grade (e.g. 5) includes all the options (e.g. the ones from both 5 and 6). In the attached picture you can see the students repeated in both 5th and 6th grades.
    Note that it’s not only matter of displaying data, but user can select twice the same student, which is a big issue in data.
    This happens only on Enketo, while Kobo app shows the grades in the reverse order, but with the correct selection on each group. I unfortunately cannot use only Kobo app for data collection.

Does anyone know how to solve the issue?
Thanks in advance!

@Giuliano, could you share with the community the sample of the XLSForm and the CSV file for community testing. That should be helpful to identify the issue.

Sure. XLSform and CSV files attached here.
form.xlsx (13.3 KB)
schools.csv (1.9 KB)
students.csv (27.1 KB)

@Giuliano, could you also let us know the server (is it the humanitarian or the non-humanitarian server) you are using?

I’m using the humanitarian server. Thanks @Kal_Lam

OK as a quick check would you mind tried it with the non-humanitarian server to see if it behaves in the same way?

Just tried and unfortunately yes, same behavior.

Hi @Giuliano, thank you for reporting this issue. It could be a bug in the latest version of Enketo. I’ll take a deeper look and create an issue on GitHub if it is :+1:

Hi @Giuliano, I have been able to replicate your issue and confirmed that it’s been fixed in Enketo Express 3.0.2. We are currently running 2.8.1 so hopefully we can upgrade soon to resolve this.