Survey question not displaying correctly


I’m having an issue with one of my survey questions not displaying properly in the KoBoCollect app. It works just fine in Enketo, but in the app, it displays a series of vertical dots and dashes rather than the drop-down menu with possible question answers (screenshot attached below). I’ve checked the XLS file and the csv file but can’t find an issue with either. I’ve also tried updating the tablet and uninstalling/reinstalling the app. No luck.

Thank you in advance!

Welcome to the community, @m_be_san! Are you using some external csv file here for this question? Would you mind sharing with us a screenshot of the question in an xlsform? That should give us a clue of what is not working?

Yes I am using an external csv/pull data for the students’ names. Here’s the screenshot:

@m_be_san, could you share your CSV file too?

Here you go!

Could you now share with us the screenshot of the choices tab especially for the choice that holds the uuid?

“uuid” is the variable name for the “Select the student’s name” question. Or should it be somewhere else in the form?

Like I said - it works perfectly in Enketo. It’s just when we open it on the android app that we get the weird lines and dots.

@m_be_san, would you mind sharing the extract of your xlsform that holds all the parts of the pulldata and also a small chunk of the CSV file so that we could test it at our ends?

I tried but it says I’m not allowed to upload attachments?

@m_be_san, you should now be able to upload files. If you still have issues please refresh your page.

CCLOMA3.csv (2.8 KB) LOMA Test.xlsx (14.4 KB)

I’ve removed all sensitive/personal identifiable information.

1 Like

When having a closer look at your choices sheet, i see that you have coded school inappropriately (with spaces) which is not allowed:

Fix this and this should solve your issue.

I recoded school to “Climbing_Club” in the xlsform and the csv file, but the lines/dots problem in the app remains.

While fixing the name under the name column of your xlsform, did you also fix the same that from under the school column which is linked with the name fixed previously?

Image 1

Yes, I did.

OK, could remove the field-list from under the appearance column and simply keep autocomplete?

Here you have used the field-list in a wrong settings. Please be informed that field-list is used under the begin_group. Fixing this should solve your issue.

It’s working! Thank you so much for your tireless efforts to troubleshoot with me.

1 Like