Surveys not refreshed in Enketo after redeploy


Since yesterday 14 March at around 12 GMT my projects are not refreshed in Enketo after being redeployed.

It is as if the Kobotoolbox server is nut pushing the new version out to the client.

@steen_andersen, are you on the humanitarian server or the non-humanitarian server?

Humanitarian server

@steen_andersen, as a quick check, would you mind …

  • … creating a new dummy project.
  • … making minor changes (edits) to this dummy project.
  • … redeploying the dummy project to see if you can refresh the project in Enketo.

Feel free to reach us back to update us on what happens!

The dummy projoct opens and I am able to deploy and Enketo is refreshed!

The two projects I am having issues with are both using:
select_one_from_file province.csv
type questions - but these have worked before - until i could not refresh Enketo with the latest version.

@Kal_Lam Now I also tried to deploy one of my older projects - and it worked with no issues.

As far as I can tell the only difference is that the ones which does NOT refresh - contains the “select_one_from_file” question types

Now I deleted the “select_one_from_file” questions and the “old” survey does now refresh.

I can change the select_one_from_file to a cascade select but the other type should also work!

I have changed the “select_one_from_file” to cascading select. And it works.
I then removed the last imagefile from the project, which was a logo image.
(see attached)
I did this to see if the logo did slow down the load of the overall project.

It did not.

Then I added the logo (image file) and I had the same issue of not being able to refresh the project.
I have now removed all image files from the settings in the project.


Have you had a change to look at this issue about the slect_one_from_file

Latest is I managed to get the logo back


I have solved the issue!

One of the CSV files had an illegal column heading (“”)
I have now managed to redeploy the project and it is refreshing in Enket0.

I create a new project as a copy of the first. The deleted everything except the select_one_from_file questions.
When redeploying the (test) project Enketo gave an error saying that one of the CVS files had an illegal heading.

The same eroor was NOT displayed when I tried to deploy the original project, which made it difficult to trace the error.
Suggestion - please let Enkoto give error also for “old” projects - not only new ones.

I have now checked my CSV files and redeployed the original project and everything is working as expected

1 Like

I am closing this issue

1 Like

@steen_andersen, :clap: :heart: :partying_face: Thank you for sharing your solution with the entire community!