The record name or ID already exists


We deployed kobo on our server, all functionalities are working smoothly and flawlessly. Just having one random problem while saving the draft and submitting the form from the desktop “ENKETO”. Users are receiving Error: The record name or ID already exists”. We already using an updated browser and we check with other browsers too like firefox, chrome, and edge but still having the same issue with random users.

The form is very lengthy. Can you please help us to fix this issue?

@Shahzadsalim, sometimes this issue should be resolved by clearing the cache of your browser. Have you tried doing the same? But please also be careful if you have unsent submissions stored in the browser. Doing so (clearing the cache of the browser) should also delete the saved submissions (that cannot be retrieved back).

Cache was also removed but issue still not resolved.
This issue arises randomly on random users’ devices. Can UUID logic update help me? or any other alternate which resolve this issue.

@Shahzadsalim, you may also need to check the device (and it’s browser) your team are using to see which device and browser are returning this issue and which are not? Maybe doing so, you could funnel down and troubleshoot.

We checked some random devices which are generating this issue. Most of the devices have update browsers and they tried other browsers too, but issue not solved.
We are also receiving duplicate entries on server with same UUID’s and user.

@Kal_Lam Do you have any other suggestions?

Leaving it open for the community to chime in. cc: @stephenoduor @ks_1

@stephenoduor @ks_1 @Kal_Lam
Error snapshot is attached for your reference.

@Shahzadsalim, could you replicate this issue with one of our publicly hosted servers? If yes, could you list out the exact steps please.

I can’t replicate this issue because it comes very randomly, and some time reported by same user which already send response from same device and browser.

@Kal_Lam any luck?