Unable to deploy my form (Issues with model as survey name)

Good morning.

I have been trying to deploy my form for over 48hrs now and am failing. Keep getting the error 500 message, i have validated my form using the online validator but still no success,Please help

The error message is as follows

500 Error unable to deploy

If this is a significant error that needs to be fixed, please send a support request to support@kobotoolbox.org with information about what triggered this error. Your form cannot be deployed because it contains errors
[erron expecting value] : 3

My username : xxxxxxx
form name production and productivity returns

@aards_monitoring_eva, could you download your XLSForm and then validate it through this online validator to see if there are any syntax issues?

After following the advice from Kal_Lam (with a downloaded form!), you may try the following:

  • Use the search function of this forum (always recommended, please), e.g. Errno Expecting value:3 (unable to deploy)

  • Check if your form uses “model” or data as question/item name.

  • Search the token “: 3” and “3” in Excel in the XLSForm and check the syntax there, incl. function arguments.

  • Try to preview the form in KoboToolbox

  • Check if you have a given_name column in the downloaded XLSForm. This would mean that the original name in the form has been adapted by KoboToolbox (but not it’s references).

  • Locate the problem (on column level) by deactivating colums stepwise: constraint, calculation, relevant etc. You can do this by temporarily renaming the column name as XX…, e.g. XXconstraint. (For the calculation you may also need to change the type temporarily, e.g. to text).

  • Locate the problem (on row level) by cutting the form in pieces and checking it stepwise.

  • Report the found solution to the community here.

1 Like

Thanks so much , problem solved had model , so i changed to modela

1 Like

@Kal_Lam, @Josh,
maybe KoboToolbox and/or the ODK online validator could be adapted to check against system-reserved names like model, data etc.?

We had several cases in the forum, and it’s difficult to locate the problem with given error messages.

1 Like

@aards_monitoring_eva, @wroos :clap: :heart: :partying_face:

@wroos, we already have a GitHub issue for this. FYR:

1 Like

excellent, i am really grateful for the support

1 Like

@Lameck see this…

1 Like

Thanks for sharing @AlexRutto77

1 Like