Unable to update some users permissions

Dears KoBo team,

I am having problem-related to updating some users’ permissions. see the following example:

I add the user with the above properties.

It will save with completely different properties.

user server: Humintrainresponse.

Kindly solve the problem ASAP.

@aamra, do you have this issue only when sharing permissions with many users, or is it also seen when sharing it with a small number of users?

Hi @Kal_Lam

The issue appeared with me in a form with many users.

Best, Abd

@aamra, you mean it’s not an issue when the permissions are assigned to a few users, but it only prevails when you have a lot of users. Did I get you correctly? Could you also let the community know the total number of users you have at the moment where your permission fails?

Dear @Kal_Lam

The total number of users in this form is 116. consider mentioning that I have layers of verifications (nearly 32 users monitor others users’ input and edit if needed).

Ah … 116 is a big number. Maybe this is the reason why the permissions keep breaking. Could you provide exact details on the total number of users (supervisors>enumerators) so that we could improve this feature?

We use this form as a system. during Covid-19 spreading, our organization created a helpline service.

The helpline staff (84 employees) will receive beneficiaries’ complaints and inquiries, and they will enter them into the form. and they have the possibility to view their entered records.

Area focal points (16) and their supervisors (16) will review each complaint and takes the needed action. each one of the staff these views only complaints that were received by the helpline from his area.

Best regards, Abd

@aamra, in your case I hope this post discussed previously should help you solve your issue:

Thanks, @Kal_Lam for your reply. Unfortunately, I don’t have a programming background and I am unable to apply this solution.

Hi @aamra, there is a fix for this issue that will be included in the next release — which unfortunately I cannot give a definitive date for.

In the meantime, since this is urgent for your project, can you please send me a list of user permissions in an Excel workbook or CSV by private message in the following format:

username view form edit form view submissions view submissions from users add submissions edit submissions edit submissions from users validate submissions validate submissions from users delete submissions manage project
bob true alice,mike true john,david john,david


  • the assigning username in the first column
  • “true” for tick boxes
  • comma-separated usernames for “X from users” columns

Hello @aamra,
I would like to clarify something regarding your screenshots.
You sentence I add the user with the above properties is a little bit confusing.
According to what you said, you granted user a_wichah with regular permissions (1st screenshot) but it has been with saved partial permissions (2nd screenshot)?

Or you wanted to say I add the user with properties *below* which means you tried to change the permissions from 1st screenshot to 2nd screenshot and the software did not save them correctly?

1 Like

Hi Everyone.

I was having this problem too. I’m on a Mac, and usually use Safari. Then I remembered that behavior differs between browsers. Anyhow, updating the very same username permissions worked fine in Chrome.

1 Like

Many thanks for your feedback. It works also with me on chrome. previously I was using Microsoft’s new edge browser.

Many thanks for your support and help. murch appreciated.