Unable to upload a form on KoBo Toolbox- Could it be a server problem?

Hi Everyone,

I had successfully uploaded a form and deployed it on KoBo Toolbox three hours ago. However, I have tried to re-upload the similar form an hour later, and it seems like the uploading process is taking too long. It’s been almost two hours, and I am still having a hard time to upload it successfully.

May I know if there is a server problem today? If so, how long will it be solved? Thank you.

Welcome to the community, @hoongyan1101! Have you validated your XLSForm through this online validator to see if there are any syntax issues?

Thank you @Kal_Lam. Yes, the form is validated. The reason that I think is the server problem because me and my team couldn’t access to KoBo login page several times today (came back as 502 bad getaway), and we haven’t been able to successfully upload the form since evening (it works fine earlier of the day). We both have tried different laptops in several locations with 2 different KoBo accounts to make sure that it wasn’t our connection problem.

Could you also let us know the server you are using? Maybe we could also have a closer look at our end?

We used Google chrome and Microsoft Edge for KoBo Toolbox login. We are unsure what server we are using, that’d be great if you could clarify. Thanks.

Could you share with the community a login URL so that we should be able to identify the server?


This is what we have used.

1 Like

Thank you @hoongyan1101! Will have a quick look at it.

Thank you for your assistance. Keep me updated.

1 Like

Hi @Kal_Lam, I just tried to upload my excel form again, and it works now! Still unsure what was the problem, but glad that it is working now. Thank you for your support.

1 Like

Thank you for confirming @hoongyan1101!