502 Bad Gateway

So i managed to get rid of 500 error (SMTP) somehow but now when i am trying to register a new user after a minute or two it shows me 502 bad gateway.

I have tried to look into run.py --logs and it shows nothing just no useful info but i will paste an image, any idea what is the bad gateway error ?

Hi @Elie,

Would you mind having a look at some of the post that has been discussed earlier on the same issue. It should help solve your issue:

Have a great day!

Hi @Kal_Lam

I will try to enable debugging and see if anything shows.but where do i look for the debugging log of the 502 ?

Hi @Elie,

Have a great day!

is this anyhow related?

bumping for any help.

i found this error in access.log - 7c7a72da73fb5aaf132815efbeca2cf37768b760cbe2d5e9d693e8fc949f422eb72ec9333f875b5be9e498788900672b0fb099f075aa5ee9c325d34c [23/Jun/2020:11:35:49 +0000] “POST /api/v2/survey/all HTTP/1.1” 404 134 “-” “python-requests/2.22.0” - - [23/Jun/2020:11:35:52 +0000] “GET /api/v2/asset_snapshots/sEKqZdvNUkgGrppQxteidJ.xml HTTP/1.1” 404 162 “-” “-”

the ip 172.25.x.x is currently used by my network, is it possible to alter the ip ?

You can pull latest version of kobo-install and not exposed backend ports.

1 Like

i am already on latest version without exposed ports.
i have created a daemon.js in /etc/docker/ and tried to use another subnet but without any success i was looking in kobo-docker for errors in log and i found those errors in kpi.errror.log

Hey Elie
Did you fix this?
im getting a “1626 upstream timed out (110: Operation timed out) while reading response header from upstream”

no i have not yet, it seems whenever i use port 25 for mail config it does a 500 error whenever i use port 587 with tls i get 502 bad gateway.
where did u get the error from ? which log file?

i have installed installed portainer.oi and saw it under the nginxcertbot_nginx.

ah u used ssl? i didnt.


i suggest u take a look at iptables or ip route and check if anything is interfering with your private network since it creates virtual adapters and assign private ip’s.

on another note i just read, the nginx is probably timing out, try to increate the timeout.

yes i saw that as well. - not sure its got anything to do with ip etc as its brand new setup.
can i edit the time out in the text file ? or do i need to do it via command?