Data table shows header with group and with no group

Hi All,

I encountered a bit weird things on KoboToolbox. On my data table, now the header shows attributes with group and with no group. Even though I’ve already chosen with group, the header with no group still appears although it shows no value (null/missing). Any help really appreciated!
Thank you!

Hi @midoen,

Welcome to the community! Would you mind sharing with the community the screenshots of the group and no group you are referring to. It would help the community to better understand your issue.

Have a great day!

Hi Kal_Lam,
Thank you for quick response.
This is what I meant:

as you may see on the above pic, the “Provinsi” attribute appear with no group, and with group (group name is: “Data Pelapor”), but the “no group” attribute appears no value at all. It goes all to the other attributes as well.
It really affects on PowerBI connectivity, it appears error on Power BI, it says no column namely “Provinsi”, PowerBI only recognize “Data Pelapor/Provinsi”. Something like that.
Is there any way to get rid of the “no group” column?
Thank you!

Hi @midoen,

You could fix this following the instructions as outlined below:

Have a great day!

Hi Kal_Lam,

Thanks again for replying. Actually, I’ve tried that. And it still shows 2 header with no group, one of them is blank value, like this:

Hi @midoen,

Could you share with us the following (through a private message) so that we are able to have a closer look at your issue:

  • Username
  • Project name
  • Server you are using (OCHA or HHI)

You could send us a private message as outlined here.

Have a great day!

Hi @midoen,

I looked at your issue in detail. Kindly please be informed that it’s nothing that you need to worry as you are not loosing any of your data. You are seeing it as a result of the way you built your survey project (but that too is not an issue). For details please read out the entire post …

While looking at your survey form i see that you have used group data:

So this was that was causing the issue.

If you download the data with the following settings:

You will see a normal placements of variables (without any blank extra variables):

So if you wish to see the same view in server you could configure the following (in addition to what i have outlined in post 4):

So once you tick the selected variables and press SAVE you should be able to see only the selected variables as shown in the image below:

Have a great day!

1 Like

Hi @Kal_Lam,

Thank you so much! Particularly at that ‘tick selected variables’ part. I missed that.
Really appreciate what you’ve done and contributed.
I’m amazed and inspired!
Have a great day!