Error Message while saving my form

I have been saving my form normally without issues But when I try to save, it returns an error message that reads:

Please try reloading the page. If you need to contact support, note the following message:
403: Authentication credentials were not provided.

How do I resolve this issue.


If you are on the server, this may have been caused by a deployment done earlier today. Do you still have the issue if you log out and log back in again?

1 Like

Thank you Jnm for the response, Indeed, I am on [ server. I was afraid of loosing my unsaved work but it appears I have no choice than to log out and login again. The error message changed though to:

Error saving form

Your changes could not be saved, likely because of a lost internet connection. Keep this window open and try saving again while using a better connection.

After logging out and logging in again, the issue is resolved and I can now save the form. However, this has happened at the cost of loosing all that I had already worked upon.


1 Like

Hi @ebizimungu,

Maybe you could download your survey project in the xlsform (and make a backup so that you do not lose the questionnaire that you have prepared so far) as outlined previously:

Have a great day!

1 Like

Hi @Kal_Lam, Thank you for the advice. I am actually now working with xlsform which I will upload when done.

1 Like

Sorry to hear that. Did you try logging out and back in again with a different tab in the same browser? If the form still wouldn’t save after doing that, and you had to reload the tab where you were editing the form, then that’s a problem we would like to fix.

Yes, I tried all that and the form couldn’t save. You may need to look into that issue. Thanks.

1 Like

We’ve logged the problem at