Error when trying to edit saved form

When trying to edit individual entries on our project, for some we get the following error message:

"Error occured during the loading of this form. It is recommended not to edit this record until this is resolved.
Please contact [] with the link to this page and the error message below:

  • TypeError: Cannot read property ‘previousElementSibling’ of undefined"

Any help would be appreciated as it looks like the email address provided in the error message is not a real one… Thanks.

1 Like

Hi @marfur,

Welcome back to the community! You mean you get an error message when you do the following:

  • Under the DATA>Table you press the pen like Edit icon to edit the submissions from the KoBoToolbox server.
  • You get the error message that you have listed above.

Kindly please confirm so that we could have a closer look. Would appreciate if you could correct me if it’s something different.

Have a great day!

1 Like

Hi @Kal_Lam,
Yes, that is exactly the process I have followed, resulting in the error message I copied.
It only happens on some forms but not on others. It’s the same for me and for others working on the project.

Hi @marfur,

If this is the case, could you kindly provide me the following information so that we look at your case more minutely (through a private message):

  • Username
  • Project name
  • Server you are using (OCHA or HHI)
  • _id number that has issues (so that i could check the same out at my end)

Have a great day!

did you change the form version after the original submission?

hi wroos, the record concerned has been registered with the version of the form that is currently deployed. I can edit others that have been submitted with the same (and earlier) versions of the form.

This happened in a project i was working on as well.
The problem was that we were using a choice-name calculation in the form. After removing this calculation, the form worked perfectly.
To help troubleshoot where the error is coming up in your form, reload the web page after filling in each answer to narrow down on the question where the error is arising from


Thank you for that hint, @arnold_njogu. I will have a look at the records concerned and see if i can find any pattern related to choice-name calculations in the form.

1 Like

Hi! I have just read the comments and that I am currently facing the same problem. I cannot edit individual entries for one of the projects that I deployeded, noting that I can preview the entries in the project itself, and that the rest of the projects I can modify their inputs… I also received an error message
Please let me know how you solved the problem…??
Thank you… :raised_hands: :raised_hands: :raised_hands: