Form won't load

Hello! One of my coordinators is having the same issue with all the navigators (Internet Explorer, Firefox and Chrome, everytime she tries to load the form she gets the message. “We didn’t find any survey with this ID”.

I load the form in my computer, with all the navigators, and it loads fine

I don’t understand what’s happening :’( Please HELP!

Hi @analucia_espinoza,

Would you mind sharing us the survey link (through a private message if it’s confidential). We would like to have a look at our end and see if the issue still persists.

Have a great day!

@Kal_Lam using the screenshot provided, I noted that the issue is with the link to the form itself. It seems the link leads the user to a form that does not exist.

I would suggest that @analucia_espinoza looks keenly on the link being used by the coordinator and confirm that the link is the same one that is working on her side. If that is the case, then it may be good to consider checking the deployment version or need for redeployment.


Hello Kal! How are you, this is the survey link:

I can load in every navigator in my computer, and my other coordinators can… Is there a maximum number of locations where you can open the link or something like that… Because this is the first time this person tried to open the link in her computer…

Hi @analucia_espinoza,

Kindly please be informed that i have edited the link you have provided as a security means. Also please be informed that I was able to open it at my end,

Sample of your survey form in Enketo (through a PC):

Sample of your survey form in Enketo (through an android device):

Also please be informed that if i am able to open the survey link (at my end), am sure your coordinators should also be able to open them at their end. With this i would like to confirm that there is no broken connection between the link and your KoBoToolbox server.

Would you mind requesting your coordinators to do the following as a workaround:

  • Request them to open a browser and see if they are able to connect to an internet. Sometimes an internet connection also creates connection errors.
  • If they are able to connect to an internet but not able to open the survey form request them to upgrade their browser to the latest possible version. Avoid using Internet Explorer. Try using Chrome or Mozilla. Sometimes the browser also causes this sort of issues.
  • Request them to use the exact characters that has been shared with them. Sometimes a typo error could also lead to this issue. FYI, while trying the link (you provided) in my tablet i too had a typo error and could not access. But then i corrected the typo and i could open the same in my tablet as well.

Please let us know if it solved your issue. It should definitely work!

Have a great day!

1 Like

Thank you @Kal_Lam! :star_struck:! Let you know if we get new information!