Geopoint widget Bug: search input does not move the map

Hi there,

this is my first post. I searched this forum but did not find anything similar. Hope this is the right place for help.

I have this live kobo form which worked well for 500+ submissions:

Since a few days the form seems to have a bug:

On page two of the form (after users click “next”, I have a geopoint widget to get the users geo location. This worked as expected either by locating via the browser or by typing a place name in the search input.

Now the search input does not return any results anymore. :frowning:

What still works is to just pan and zoom the map and click somewhere to set latitude and longitude, but it makes it very hard to use for the users.

What I tried:

  • I tested and confirmed the bug in both the English and German version of the kobo form
  • I tested and confirmed this bug in various browsers (iOS Safari, Chrome Mac, Android…)
  • I checked the admin interface but the form was not changed since July 11th

My guess is that it is a bug on the Kobo toolbox version which runs on (which I have no control over). Any idea how I can debug this better and/or get support from someone else?

I can post the XLSform if that helps. The row which is relevant is:



label::Deutsch (de)
Markiere exakt den Eingang zum Ort auf der Karte. Falls es mehrere Eingänge gibt, markiere den Haupteingang.

label::English (en)
*Mark the entrance of this place on the map (If there are multiple entrances, mark the main entrance). *

hint::Deutsch (de)
Du kannst auch deine aktuelle Position bestimmen lassen

hint::English (en)
*Your current position can also be determined by your device *

maps hide-input


Any ideas?


1 Like

Hi @Holger,

Welcome to the community! Please click to the padlock and then select allow under the location as shown in the figure below.

With this you should be able to select the location from your browser.

1 Like

Hi Kal_Lam,

thanks for your suggestions. Unfortunately that did not solve my problem. I am permitting location in my Chrome browser. As said, I tested it with multiple browsers without success and also got user feedback reporting the same issue with the geopoint form.

Any other ideas?

After further testing it tuns out, that the geocode queries for Google Maps (which are running the geopoint widget) are over quota for the domain on which my form is running on.

  • The kobo/enketo geopoint widget uses Google Maps under the hood for geocoding
  • The maximum amount of search queries for the domain has been reached. (“over quota”)
  • Therefore no more geocoding is possible for my form which runs on this domain

I will reach out to the info email of but also hope this might be helpful in this forum for other people who run into the same issue.

1 Like

This is an example for a request performed by the widget:[redacted]

The response shows the quota problem:

  error_message: "You have exceeded your daily request quota for this API. If you did not set a custom daily request quota, verify your project has an active billing account:",
  results: [ ],
  status: "OVER_QUERY_LIMIT"

Thanks for your patience, everyone. We’ve raised the Google API quota and I’ve confirmed that @Holger’s form now geocodes properly.

@ff_mutaphysis, thanks for your minimal test case—it was helpful for confirming the fix! I’m going to redact our API key from your post (even though someone could easily get it from Enketo), just so it’s not hanging out there in too obvious of a way :smiley:

1 Like

This is awesome, it works now! Thanks for your quick help! :heart:

1 Like

Dear All,
FWIW, this is exactly the same bug as the one I reported here 2 weeks ago. Thanks for solving it!