`kobo-install` on a fresh Ubuntu 18.04 LTS VPS

Hi guys! My installation is stuck at this point. I am trying on a Ubuntu 18.04 LTS with 8 GB ram.

kc.mydomain.com, ee.mydomain.com and kf.mydomain.com are also working but mydomain.com is not working. Does anyone have any idea as to what might be the issue?

@stephanealoo @Kal_Lam @Elie @nolive

Hi dear

No i can’t solve this problim yet i am writing the reply .

If you speak arabic send to REMOVED PHONE NUMBER

@ramiz please don’t tag people en masse like this. Supporting people’s private installations of KoBo is not our central mission, and we try our best to help only as time permits. If that’s not enough, you can post on the job board and hire a professional to help you.

Could clarify the problem? KoBoToolbox only serves three hostnames: KPI, KoBoCAT, and Enketo Express—the ones you say are working—and if you want a fourth domain (the base mydomain.com), you need to arrange for that separately. For example, our public instance runs on kf.kobotoolbox.org (KPI), kc.kobotoolbox.org (KoBoCAT), and ee.kobotoolbox.org (Enketo Express). The root domain kobotoolbox.org is hosted by GitHub Pages, completely separately from the KoBoToolbox application.


I don’t see any errors. Maybe there’s a DNS problem, or an issue with KoBoCAT or Enketo Express (their logs are not visible in the screenshot). What happens if you try to visit each of KPI, KoBoCAT, and Enketo Express in a browser? Usually these will be kf.yourdomain.org, kc.yourdomain.org, and ee.yourdomain.org, but it depends on what you chose when you first ran the run.py setup.

1 Like

Hi! Sorry for tagging people, The problem has been solved. I’ll write about it in the next comment


I was making two mistakes here:

  1. I was giving full subdomain address instead of just the subdomain. So for example, instead of writing “kf” I was writing “kf.mydomain.com
  2. I was running it with the root user

Fixed these two and it started running with http.

Now my next step is to run it with https. There I get stuck. Now none of my subdomains work. In the logs I see this:

The setup just keeps on running infinitely (until I stop it) without any error. This is what I see:

My server’s port 443 is open. When I try to open https://kf.mydomain.com/ it keeps on running and after some time, I get 504 timed out error from nginx. What could I be doing wrong?

1 Like

Run docker ps and see whether the containers are up? Check the container logs too.

504 for me gets solved when I restart the containers.

1 Like

I tried docker ps. The cotnainers seem to be all running except nginx:1.15-alpine. But there is another Nginx container that is running

Thanks! I was able to see in container logs, the error message was: cannot load certificate “/etc/letsencrypt/live/mydomain.com/fullchain.pem”
Although it should have been there. Now I need to see why it is not there. Atleast I have a lead now.

If you need to add the SSL certificates manually, you can use this process:


Thanks a lot! I will try again tomorrow!

1 Like

Thanks a lot !
the problim was in DNS

But i want to ask about what is the defaults port for every sub domin as kc,kf,ee

Hi! I tried to do it automatically for now. In the logs, everything looks fine but the form won’t open. In the nginx logs, it shows the following error:
SSL: error:141CF06C:SSL routines:tls_parse_ctos_key_share:bad key share
Does anyone know how I can fix this?

Looks like an issue with the key file. Either you can execute run.py --setup or use the manual method above to try and reinstall the keys.


Have you solved this issue?

If yes, kindly post how did you solved it.

enketo express form preview issue has been resolved:

added entries in docker-compose.frontend.override.yml for extra hosts as described:

  - kf.mydomain:
  - kc.mydomain:
  - ee.mydomain:


Thanks for this. But I have followed it to the letter and still have not been able to get past the “Waiting for environment to be ready. It can take a few minutes.” line.

Is there some other way I can inspect and (perhaps adjust variables) to get it running? The logs show everything is up and running but I get a secure page saying “504 Gateway Time-out.” Where in the containers, for instance, should I look for what I may be missing because I can’t seem to find any clue as to what I may be doing wrong.

What else can I do because I seem to have ran out of ideas. And I’ve read all the docs posted here.

Thanks in advance.

I am unable to start my environment with a custom domain. I have added the A record entry of my EC2 public IP against the three subdomains (kf.[mydomain.org], kc.[mypublicdomain.org], ee.[mydomain.org]) in my DNS provider’s console. Now when I start my environment by “sudo python3 run.py --setup” command, I get stuck in the start of the environment. All the containers are up and running. But my installation remains stucked in “Waiting for the environment to be ready” line. What do I need to do to use my own public domain?
Do I need to add an A record entry for my root domain as well?

Hello Kal,
I hope this message find you will!

Could you please confirm if I still can me install kobotoobox on my server ubuntu 20.4 Azure VM?
And how?

becuase i’ve tried a lot of methods and they don’t work for me

Any body can help me?

  1. KoBoToolbox has not started yet. This is can be normal with low CPU/RAM computers.

Wait for another 600 seconds?

  1. Yes
  2. No
    [1]: 2

║ ║
║ KoBoToolbox could not start! ║
║ Please try python3 run.py --logs to see the logs. ║
║ ║

when i run python3 run.py --logs
there is no error!!