Media Files are not detected (error) on Preview and OPEN (Collect Data)

Hi All,

We are encountering Loading Error or Media Files are not detected since yesterday on Preview.
As result, in android phone, From dropdown list are not avalaible.

@andis, it seems like your form has some CSV files, but they have not been uploaded to the project. The other issue is that the CSV file name has been wrongly named in the XLSForm.

Check these two and that should solve your issue.

@Kal_Lam, Thanks for the response.
We have been doing update every twice a day. Previously there is no problem. This happen since yesterday.

The CSV files shown well on media files after uploaded. But the problem is they will not be detected if preview the form after deployment.

@andis, so you mean the issue is only with the preview and not when collecting or submitting your data? Did I get you correct? Could you also let us know the server you are using?

It also happen when we access it from Android Phone when data collector try to fill the form. Dropdown list are not available.

How do we know the server we are using?

@andis, I hope the CSV file is still not linked properly. My advice here is that you check the following:

  • Check whether the CSV filename and extension are named correctly in the form and are also available on the server.
  • Check whether the CSV file format is correctly formatted.

@Kal_Lam We are automatically update the csv files every 15 minutes. I believe that’s not the issue.

Anyway, how do we know the server we are using? how we know that the files are on the server?

@andis, you can share your KoboToolbox login link with the community to let us know which server you use. To check the CSV file in your server, go to Projects>SETTINGS>Media as shown in the image below:

we’ve been using this format for a year. We also have tried to upload the old csv files when everything is okay. But the problem is just the same.

Here the link. We are using general server.

The csv files are there

@andis, would you mind sharing with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

@Kal_Lam I have already sent private message. Please check. Thanks!

1 Like

@andis and I figured out a solution. We followed pkinuthia’s recommendation in the following post: KoBoCollect is not able to get forms with media - #22 by pkinuthia

This seems like a bug that should be addressed in future updates.

@barefootocean @Kal_Lam

Yes, It’s working with this scenario :

  1. Delete the itemsets.csv file,
  2. Deploy the form.
  3. Go to media and add the itemsets.csv file
  4. Deploy the form

But for normal scenario below,

  1. Delete the itemsets.csv file,
  2. Go to media and add the itemsets.csv file
  3. Deploy the form

It’s still not working.


@andis, @barefootocean, :clap: :heart: :partying_face:

thanks andis it worked for me as well. God bless you.

1 Like

@nadeemuddin, :clap: :heart: :partying_face: