413 error (no resolution yet)

Hi there,

I’ve searched through the forums but I’m still unable to find a resolution. Is there anyone out there that can help with the 413 (generic exception) error? I assume this has got to do with the file sizes of the photos and/or videos I am submitting to kf.kobo. However, I have not exhausted my data allocation at all. Are there file size limits I’m not aware of for photos and videos, and if so, is there a way to resolve this so that data can be uploaded successfully to the server. I have tried both single and bulk submissions.

Thanks for your help!


Welcome to the community, @landwatersci! Could you kindly share a screenshot of your error message so that we can understand it pictorially? Please also let us know the server you are using. That should help us replicate your issue in the server that has the issue.

Hi @Kal_Lam. Thanks for your response!

I’ve attached a screenshot for you to look at. Note, I’ve blanked out the survey name and device ID just in case for security. The data is sent to kf.kobotoolbox.org, under the non-humanitarian account.
Note, the data is collected from KoboCollect on Android. A proportion of the forms have sent through, with pictures and photos. But there have been failures as well.

@landwatersci, you mean this particular device failed to submit the submission while other devices did not have the submission issue, correct?

Hi again, and sorry for such a delayed response. I have once again just heard that some of the videos are still not submitting. It has just been from one device, in which components of the forms (e.g. videos and photos) have not been submitting through to the server. The remaining content (e.g. form answers and non-bulky content) appears to be submitting through just fine. I’m curious is this is an upload limit issue?

In the meantime, we will transfer the content directly off the device via USB, but it will be great to know for the future if we can just upload directly to the server.

1 Like

@landwatersci, could you kindly check the image size of your media that is not being submitted? Maybe this should give us some clue of what is happening. My initial guess is that the image/media should be very large (which the system would not allow) as it time out to such requests.