504 gateway error while loading kobo records


*Description of 504 Gateway

Steps to Reproduce

  1. … While opening the data table on kobo and writing ids in the toolbox, it takes longer to respond so much that it fails to load the results. I have 6445 entries on kobo (a questionnaire based study) and to edit entries, it fails to load the saved data on kobo

Expected behavior

For data entries to load

What you expected to happen
for kobo entries to load and to edit each data entry saved on kobo

Actual behavior

504 Gateway error

What actually happened, you can add screenshots if applicable

Additional details

Your environment, why you think this might be happening, or stuff you tried that didn’t work
I am working on Windows 10, 64 bit operating system

- What should topics in this category generally contain?

- Do we need this category? Can we merge with another category, or subcategory?

Welcome to the community, @shailjaaa90! Could you also let us know on when have you started getting this error message? Would you also mind letting us know the server you are using?

Thank you for your swift response and your help.

I am using the server for researchers (non-humanitarian), and the trouble started a month back. I have 6445 submissions, and I am unable to load them on my laptop.

Thank you @Kal_Lam

My server is https://kf.kobotoolbox.org/#/forms/aTFKbXVf9UifkDU9TtpHif/data/table, and I am facing errors of bad gateway 502 and gateway timeout 504 intermittently. I am getting this error when I am trying to open a record for editing. I hope this information helps to guide us. Just now, when I tried, the edit record page is opening, but there has been an issue with it intermittently, and I am afraid that the issue might happen again.

Thank you in advance for your support.

1 Like

Hi @shailjaaa90
Thanks for indicating that this issue no longer exists; it had occurred intermittently. One suggestion would be that the next time it occurs, kindly run the console (Ctrl+Shift+J) and indicate which additional errors you can see.


1 Like


Thank you for your response, I will try the console, but somehow the situation of gateway 504 and 502 still exist. Please help in this direction!

Thank you very much.

@shailjaaa90, could you share with me the following through a private message:

  • Username
  • Project name
  • Server

@Kal_Lam I am unable to send you a private message.

Please let me know and Thank you.

Attaching screenshot for your reference @Kal_Lam

@shailjaaa90, you should now be able to send me a private message.

@shailjaaa90, I made a quick check and did not find any issue with it:

FYI, I could load the page with Chrome browser.

Dear @Kal_Lam and @stephanealoo following your suggestion these are the errors I am getting in the console, in case that can help to clarify the issue… Thanks a lot for your help.

@Kal_Lam I am unable to upload the kobos as I have sent you the screenshot for the same.

Gateway 504 and 502 issue persist so please let me know.

@shailjaaa90, which browser and OS are you using? I tried this with Chrome on Windows 10. Would you mind trying it out on a similar configuration to see if it works for you?

@Kal_Lam Thank you for your prompt response and help. I am using Chrome browser, and the operating system is Microsoft windows. I have been using a similar configuration, Chrome on Windows 10, and have lately faced Gateway 504 issues.


I am sorry to insist. If that can be of any help, here is how exactly I am getting to the error.

  1. I am logging in
  2. clicking on the deployed project (only one is available)
  3. I am then going on the data tab
  4. I am filtering the data with a random ID number
  5. Click on the edit button to open it
  6. Alternatively getting the 504 error message;
    It also happens to other people in my team having different configurations (Windows 7, Windows 10, Mac OS X, Macs OS M1…) with various browsers. Then it doesn’t look like a configuration issue if I interpret it correctly. Rather a server issue I guess ?
    Thank you in advance.

OK, as a quick check would you mind trying it without step 4:

@Kal_Lam, Thank you for your response. I have 6487 entries, so to load a particular kobo submission (draft), I’ll have to enter the particular ID in the data column. So step 4 is part of the data manipulation.

hi i have the same problem

@Kal_Lam and @stephanealoo, I hope you are well.

The problem persists with Kobo, and it is Gateway 502. Please could you kindly check,

Thank you, Appreciate the help as I am on a deadline and can’t afford the delay.