Android kobo form closes when clicking 'add' to repeat a group

We created a form with nested repeat groups. We encountered several issues:

  1. Issues in the preview online:
    The overall group (‘observations’) shows up fine in response to a Yes/No question. But the groups within that should show in response to a ‘select one’ question do not show up in the preview (but see below: it works in the app).

  2. Issues with the form in the application
    The ‘observations’ group starts ok. The groups within start fine too and repeat the number of times they should repeat. At the end of these repetitions, the app asks if the user wishes to add another observation (repeating the overall group), which is what it is supposed to do. BUT, when clicking ‘add’ the form simply closes and the app returns to the start screen rather than restarting the ‘observation’ group.

I tried to add the file here, but I’m not permitted. Adding the link in case that helps:

Am I missing something, or is this a glitch?

I just tried it with KoBoCollect v1.27.3 and could replicate the issue you have outlined above. However, when trying the same with ODK Collect v1.28.1 i did not see the issue. Maybe it would be good if you give a try with ODK Collect v1.28.1 which has more bugs fixed and features included when compared to the latest release of the KoBoCollect v1.27.3. FYI, KoBoToolbox is also updating it’s latest release of KoBoCollect android app' to v1.28 soon. In addition, yes, the data can also be smoothly collected with Enketo` if you wish to collect your data through the web browser.

Maybe the community would also benefit if i share you nested repeat structure:

begin_repeat (with repeat count .a)
begin_repeat (with repeat count .b)

Thank you. I just downloaded the ODK app, and the same issue occurs. The within groups repeat just fine, and if I click ‘do not add’ for the observation group after recording data, the form also goes to the correct next question, but clicking ‘add’ closes the form and a message appears saying the application keeps closing. Anyway I can program this differently for it to work correctly?

Could you kindly share your xlsform with the community so that the community could test the same and see if it’s still an issue.

Here is the xls form. The online version seems to work ok, but the issues in the application continue, even in ODK. Hoping the community can help.
Thank you!

awvrN6rdhZpCwFzKBVfJC7-3.xlsx (11.3 KB)

I just tried with ODK Collect v1.28.1 and did not face any issue. Maybe some of our community members could also help you by testing the same at their end.

Strange. I tried in ODK Collect v1.28.1 too and it gives me the same error - form goes back to the main screen rather than starting a new group of observations. I’ve asked colleagues to test on their phones too, but assistance from the community would be greatly appreciated.

Would you mind trying this on a different device?


I thought that maybe the condition to start the group was the problem, so I removed that and also simplified the form to no longer have nested groups, thinking that this is where the app may have issues. In Kobo, I continue to have the same issue, but in ODK adding another group worked and sent me back to the start of the group for a new data recording. BUT, as soon as I select the answer that is a condition for the following questions, an error occurs (see screenshot attached). I’m happy to at least have an actual error message showing that can guide the solution, rather than the app just going to the start screen when adding a group. The error seems to be in the conditions put on the questions, but I don’t see the error.

Could anyone please take a look and see what may be causing this?
The xls file is attached.

Thanks so much,


aods97qWjEB7tLGX5mCPvw-2.xlsx (11.2 KB)

I now see an issue with your xlsform. When trying to validate here i could see this error message:

The issue is in row 43 highlighted in the image below:

You have tried to use an expression that is applicable within the repeat group (as the variables you have tried to express are within the repeat group but have used them outside the repeat group). This is why you are seeing the error message.

1 Like

Thank you so much. This must have been the problem since the start. I corrected this and the form is now working fine.


Glad to know if finally solved your issue!