Auto Send option in form management from Kobo collect does not work

Hi folks,

I want the forms collected to automatically be synced to the server without giving the enumerators “Edit saved form” or send the forms manually.

For this purpose I have adjusted the auto send from form management to “Wifi or cellular”. but still when filling new forms, they will go to “Edit Saved Form” and also will be seen in “Send Finalized Form”, Does it require specific duration to be synced or what’s the problem??

FYI I’m using “


Welcome back to the community, @BarzanAAli! Which version of the KoBoCollect android app do you use? Have you tried this with the ODK Collect android app too?

Thanks for the swift response. We’re supposedly using the latest version KoBoCollect v1.29.3. And No we have not tried ODK. We’re collecting data (1000+ records) on daily basis from 26 different locations and we’ve used KoBoCollect app for all.

OK, so as an additional check, maybe you could hide some buttons if you feel like the enumerators should not be able to edit the submissions once the survey is completed.

For this you could configure your KoBoCollect android app as follows:

  • Go to Admin Settings
  • Select Main Menu Settings
  • Now uncheck the menu that you wish the enumerators should not be able to access.
  • After making the changes, ensure that you set the admin password through the Admin Settings>Admin Password.

I have tried it, but the problem is the records are not automatically synced! I revert back the settings again to see “sent finalized form” and the records are still there.

Were you able to automatically sent the submissions to the server without any issues previously?

@BarzanAAli, I made this test (with both the Collect android app i.e. KoBoCollect android app as well as ODK Collect android app) and it worked for me (i.e. I could send the collected data automatically to the server). But, please note that it took a lot of time for the first one. It should definitely work for you too.

Thank you so much it worked with me also but it took a lot of time indeed.

1 Like