Cannot download project in xls format

Hi there, for some reason, I cannot download my (deployed) project form in xls format (not the data, I want the questionnaire :slight_smile: ). When I click download xls nothing happens. No error message, no download, no reaction, nothing. I tried 3 different browsers, no change.
Thanks for advice,

Hi Anna.
Welcome to the community. Could you confirm which server you are on? Also kindly share screenshots of the failure you are seeing?


1 Like

Dear Stephane, thanks for your fast response.

I am on the humanitarian server and I don’t get any response, nothing. I tried to clone the project now but same result, I cannot download the xls. When I click nothing happens, no error, no refreshing of the page, nothing.

I want to download the questionnaire for a training and need it in xls format. Happy to give you access to my account if that helps.

Thanks so much in advance,


Could you kindly share your username and project name through a private message as outlined here:

Would like to see the same at my end.

It seems I cannot send a private message. I get the following error: Cannot send private message to that user!

My user name is xxxxxxx, same problem for both projects. I tried with 2 different internet connections. 2 different computers and 3 browser. I had never had that problem before.

Thanks so much for your help. Great support at Kobo!

1 Like

Just checked it at my end and was able to download without any issue. Kindly please check in your private message, i have sent you both the xlsform through a private message.

1 Like

Fantastic! You are such a wonderful support team! Many thanks.


I am also having exactly same issues here. Can anyone help? Thanks in advance.

Could you kindly please provide us as much detail as possible so that we are able to dig into your issue.

Hi Kal_Lam,
Thanks for your kind response. When I click on ‘download .xls form’, it just does not work, does nothing, says nothing or shows nothing. It seems like I did not click on anything. While clicked, menu just disappears. Important to note that, this does not happen always. Sometimes, forms is downloaded with only one click. That’s not very often. Thanks for your support.

Would you mind checking your issue under the following conditions:

  • Different browser than what you are using currently
  • Different project that what you are looking at currently


Welcome to the community, @sibusiso! Could you share with us a screenshot of your issue so that we could have a closer look at it?

Thank you @Kal_Lam . Please find screenshot attached below. When i click download xls, it gives no action or error

OK, would you mind downloading your xlsform as outlined in the image shared below:


Hello! I have the same issue - can’t download any XLS forms from my kobo after editing in the kobo tool. Can you help me to download the form ASAP?

Welcome to the community, @Darya! Maybe you could clone your project and then download the XLSForm. If that too does not work, you could clone the previous version of the project and then download your XLSForm. That should solve your issue.

Hi @Kal_Lam ,
I am also having same issue . Not able to download the XLSFrom.

Welcome to the community, @sandip! Are you still not able to download even after refreshing your browser and clearing the browser’s cache? Kindly please let us know what happens with the workarounds provided?

I have tried with the mentions possible solutions but still not working