Can't file csv using pulldata

Hi I am trying to pull some data from previous form using pulldata() function, i have read other related topics and done everything as mentioned in the tutorial/forum topics - like saving csv in utf-8 format, redeploy after adding csv file to media.

but still getting error message Can’t find vasa.csv

Please help to resolve


Welcome to the community, @whpkobo! Could you also share your CSV file with the community so the community could also have a closer look at it to see if there are any issues there?

vasa.csv (1.9 KB)

Hi Attached please find the csv file

Hi @whpkobo,
Have you tried with “CSV (Comma delimited)” format. I have previously worked with this CSV format for pulldata and it worked very well. You can try once, hope it will work.

1 Like

Not working with comma delimited format also

@whpkobo, could you also share the relevant part of your XLSForm so that the community could also test it out for you?

a3EwuKW9kK5fKko24sPJ3A.xlsx (9.8 KB)

Hi Please find attached the XLS file with pulldata function

@whpkobo, the column name meta/instanceID is not supported.

Image 1

I changed it to meta_instanceID and it worked.


Data entry screen as seen in Enketo:

Reference XLSForm:

a3EwuKW9kK5fKko24sPJ3A.xlsx (8.4 KB)

Reference CSV file:

vasa.csv (1.9 KB)