Can't find a suitable configuration file in this directory or any parent. Are you in the right directory?

I have installed docker 18.09.0 and docker-compose 1.23.1 installed on my ubuntu 16.04 but when i type docker-compose pull it gives me the error as written in the title of this question,in addition it says Supported filenames: docker-compose.yml, docker-compose.yaml i do have a file named docker-compose.yml in my current directory though.Any help will be highly appreciated.

Hi,

Not sure if it’s the same issue, but I had a similar issue on a new test server about a week ago. I think it was related to this github thread. For me, re-installing Docker-compose as xy2z commented worked for me.

No idea if it’d work for you, but thought I’d reply just in case!

Cheers,
~ Dave.