Can't show images in forms


I have a problem with adding images in forms.
Preview mode: All is shown
On the form deployed: no image. There is a little icon and “image”.

I’ve seen 2-3 topics on this problem but no answer.
Anybody has solved this problem ?

You may try to re-deploy the form.

1 Like

@Dabertch, as advised by @wroos you will need to redeploy your form if you have recently updated/changed your image to the server.


Thanks for your answer.
It was already done a couple times and it didn’t work :cry:

@Dabertch, did you also check the image name used in the XLSForm? Sometimes it’s different, which is when the images do not load in the form. Let us know what happens.

I typed it by myself on the form to be sure there is no mistakes.

The preview works. It shows the picture. It’s only on the published form the picture doesn’t work…

@Dabertch, could you share with me the following information through a private message so that I could have a closer look at your case:

  • Username
  • Project name
  • Server

Note: You could share with me a private message as outlined in the post discussed previously:

Ok I just found why it didn’t work.

Hosts file was misconfigured.

kf, ee and kc were mentionned at a local IP address like
That’s why Kobo could show images in preview mode.

I’ve changed this local address to public IP and it worked.

Thanks a lot for your help and your reactivity.

Hope I will not face anothers problems :slight_smile:

1 Like

@Dabertch, thank you for sharing the solution with the entire community! :clap: :heart: :partying_face: