Data is lost when correcting data in a submitted form

Hallo Stephane,

This is what happens with the same form in Kobotoolbox, when I try to edit a submitted form the search-function within the repeat does not work.

Step 1: opening Data/table in KoboToolbox

Step2: I try to edit the upper survey in the list: the one with the species “Gladde witbol/Holcus mollis” and “Acer japonicum”.
The form opens and I see the string I entered: “holc”, but the list of species does not appear

If I hit the box where the filtered list should appear I only see this:

I tried to change the first species (repeat 1) “Gladde witbol/Holcus mollis” by entering a new string “trifol” and I choose “…”, just to see what happens

I tried to change the second species (repeat 2) “Acer japonicum” by entering a new string “Lotus” and I choose “dutchscientname_key”, just to see what happens

As a result of these tests I see that species 1 remains unchanged, and species 2 has changed to “code_key”.

Best regards,
Bart Roelandt

Hi @BartRoelandt
Aha! This is a known behaviour. Since you are using the webform to edit, it is affected by the limitation of search function which only works on the collect application. I hope this clarifies the issue you have been facing.
Stephane

1 Like

Hello Stephane,
Thank you for the clarification.
But is there a solution? Is this known imperfection something that will be fixed in a next version of KoboToolbox? Or is there a workaround by designing the form in another way?
Because this is the core-function of our form: the collecting of species-data.
Best regards,
Bart Roelandt

Hi,
Unfortunately there is no timeline for the implementation of the search functionality on Enketo which is what is used for webforms and hence editing the forms.

Stephane

1 Like

Dear Stephane

This is a very long thread which seems to take several detours into details which are not directly related to what is probably the core of the discussed aspect: Is it not possible to edit data in a form which uses an external file, like with appearance <= minimal search(‘facilities_ls’,‘contains’, ‘org_label’, *, ‘org_empty’, ${empty})? The solutions mentioned somewhere in the thread don’t seem to be related to this core question.

I think it would be very helpful for the community, if you added a short summary of the conclusion on this question. Thanks so much in advance!

1 Like

Hello,
A KoBo advice should be given? Avoid using search (and autocomplete?) option if you want to be able to edit submitted cases later on server level?

We couldn’t find a hint on this in KoBo support documentation https://support.kobotoolbox.org/question_options.html?highlight=appearance#appearance-optional and the links there.
Even not in https://xlsform.org/en/#appearance

An Enketo restriction is noted here, but only for select_multiple (should be corrected?)
https://xlsform.org/en/ref-table/ - see autocomplete.
This problem seems independent from pulldata context?

1 Like