Data missing problem

Hello,

I have a Kobo Server, installed with the kobo-install, working since some months, but since some weeks, i cant Download the Data from the firsts months, when i export to a XLS, only shows a few lines, and the web interface, i can see that are more then 30 submissions.

I also tried to go to TABLE > DATA and check for the missing submissions, but i get the error Error: could not load data"

Does anyone can give me some directions.

Thanks

Hi @raven,

Welcome to the community! Seems like you are using your own server to store your data collected through KoBoCollect. In this case we would advise you to contact your server provider (administrator) to support you with downloading your data.

However, thank you for putting your concern!

Hello @Kal_Lam

Thanks for the answer.

In this case, i am the administrator of the server, as i described, installed the Kobo server and now i am facing this problem and i don’t know enough of the tool to fix it.

I know that because is my server installation, i cant have official support from the developers, but i was just hopping that someone have a similar problem and can give some directions.

Thanks.

1 Like

Hi @raven, there’s a Mongo database that serves as a kind of read-only replica of submissions. Postgres stores the authoritative data. Sometimes Mongo can fall out of sync with Postgres, and KoBoCAT has a Django management command to bring it back in line. Try this:

  1. Enter the KoBoCAT container with docker exec -it kobo-docker_kobocat_1 bash
  2. Use this command inside the container to synchronize MongoDB with Postgres:
    root@kobocat:/srv/src/kobocat# ./manage.py sync_mongo --remongo
    
  3. Type exit to leave the container.

Let us know if this fixes your issue.

1 Like

Hello,

Thanks so much, this solved the problem, i can access all the data now.

2 Likes