Data not syncing with the server

Hi @Kal_Lam

I have also faced this problem like Cesc. I just wonder if this problem has been solved. I have tried to follow your all instructions but there stills an error occurring. Could you please give me and help to tackle this issue. Thanks,

Welcome back to the community @chanmony! Would you be specific with your issue so that we could troubleshoot it. Kindly please try to be specific and detailed. Also please try to provide screenshots if possible. This should help us better understand your issue.

Thanks for your prompt responses @Kal_Lam. I have used Google Drive to store data and all forms are uploaded into Google Drive. As can be seen in screenshot below, after I completed filling the form and click save form and exit at the end, then it appears like this "Not exactly one blank form matches this jr_form_id. Form has not been saved as finalized’’. I already followed all your above instructions, but still occur this problem. Your help would be really appreciated.


OK, so looking at your screenshot i can guess that your Collect android app should have forms that are not complete (where some mandatory questions should be missing). Could you open them and complete them. Maybe you will need to go through each and every questions one by one.

Note: If your survey had been complete your counter in Edit Saved Form and Send Finalized Form both should have (3).

I have checked my forms and every questions are filled in and also check on ‘mark form as finalized’, but this issue is still not solved. Or other things else cause this error? Thanks

OK as a cross check would you mind making a dummy submission (filling all the questions) and then try submitting the same to your server. Let’s see if the same gets stuck in your device.

I tried to make a dummy submission as you suggested, but still get stuck with this issue.

Are you able to pull a blank form to your device? Try it in a different device so that your forms (those stuck in your device) do not get messed up.

Yes, I also tried this approach and I used three devices to get a blank form, but it appears this issue for all devices I have utilized.

Would you mind checking the survey project if it’s still present at your server?

There still exists at my server

Which server are you using? Is it a self hosted server or are you using one of the servers hosted publicly by KoBoToolbox?

I used Google Drive (google spreadsheet) as a server to store all submission data.

But you are showing us the KoBoToolbox server in the image shared above.

the image uploaded above is the humanitarian server by UN OCHA.

Hi @chanmony
If I understood you correctly, you have set your data to be submitted to google sheets. Probably using the approach that has been explained here.

I believe this must be an issue with one of your authorizations to submit to the specific google account that you had linked. Could you test the process on a different phone/tablet by installing the system afresh and see if you encounter the same observations then this is definitely the issue?


1 Like

Hi @stephanealoo,
Yes, I set my data to be submitted to google sheets. I apply your approach and test it with different devices, but still had the same problem.

Are there alternative solutions for this matter? Thanks

Have you gone through this post discussed previously (it should solve your issue):