Default form automatically comes back and does not allow the "grid" form

Hi all,

I apologize as this post is really similar to another one in 2019, but I did not find a solution there, as the problem seemed to be solved at the time.

Every time I change the layout on my form to “grid” (since I have several matrix question), it automatically comes back to the default form in single page layout.

Would you have any information on this subject to help me?

Thank you in advance.

FG

Welcome to the community, @fanie! Did you build your survey form with XLSForm or Formbuilder?

Thank you! I built it with Formbuilder

Did you change the layout setting to grid-theme as outlined in the support article Using Alternative Enketo Web Form Styles? Note: You will also need to SAVE the changes you made.

I did multiple times, even though it is saved, if I refresh the page or leave and come back to the survey, the setting is back to default-single page.

Fine. Could you deploy after saving your form and then check it out in Enketo (web forms) to see if the action has taken place?

I did deploy it, multiple times as well and it still gets back to the default layout…

And when deployed, the datas in the XLS document do not include the questions that were put into matrix form, since I cannot set the layout to “grid”.

Should I just remove every matrix questions and make them into other question type ?

@fanie, deploy your survey project with the matrix question and then try filling a sample form through the web form. If you see the grid-theme display, then that should solve your issue. It should be an issue if you still do not see the grid-theme display when collecting data.

That is where the bug is, I can see the matric questions when answering on the deployed form, but the related data (the data answered in the matrix questions) is not included when I download the results in an xls form. So I can not use it nor see it.

Great!

So you mean you wish to see the entered data in the matrix form while downloading the data as XLS format too?