Default text of the non-answered questions

Hi all.
There is a text (none selected) that is populated for all non-answered questions, and it only appears in English rather than the desired language. I was wondering if there is a method of changing it? other than workarounds to insert a hint in the desired language.

Attached picture (edited to add another one) to clarify the idea, and please amend the title/tags if there is a category of what I am asking for.
Many thanks in advance!

Beside the form settings, you may need to
- make sure that you defined the 2-letter language code for all used kanguages, e.g. label::English (en), see Adding Another Language to your XLSForm — KoboToolbox documentation.
- set the Collect App settings on the local device to the other language too.

1 Like

Thanks for the response. all language are properly defined.
As for the device local, I dont think that is possible because we are collecting data through the respondents devices and not enumerators.
But, while writing this reply, I realized that their devices local should show that in the desired language. If there is no specific solution, you are kindly requested to mark this as resolved.

Do you use Collect or Enketo (Webform)?
Did you check the form with the Online validator,, please? (Always recommended during development and before deployment.)

1 Like

I am using Enketo, checked the form using the online validator, and the result is still the same. Please dont worry your self too much about this, as its one of the “good things to have” but not really a big issue.
Many thanks.