Docker install (port binding issue?)

Hello everyone.
I can’t access frontend app (KPI).
I’ve followed kobo-install instuctions to install kobo.
My setup is W11 host, Win Docker Desktop, Ubuntu on WSL2. WSL2 has a venv and is executed inside venv.
Backend part seems fine: I can connect to pgSQL instance and I see tables.

But this is what is happening with frontend (KPI instance):
Docker Desktop Containers tab (where it says 2.023.52c: so it’s the latest as of today):

Docker Desktop KPI Container > Inspect tab:

"PortBindings": {},
"NetworkSettings": {
	"Bridge": "",
	"SandboxID": "59cc765a8eb99b...",
	"SandboxKey": "/var/run/docker/netns/59cc765a8eb9",
	"Ports": {
		"8000/tcp": null
	"HairpinMode": false,
	"LinkLocalIPv6Address": "",
	"LinkLocalIPv6PrefixLen": 0,
	"SecondaryIPAddresses": null,
	"SecondaryIPv6Addresses": null,
	"EndpointID": "",
	"Gateway": "",
	"GlobalIPv6Address": "",
	"GlobalIPv6PrefixLen": 0,
	"IPAddress": "",
	"IPPrefixLen": 0,
	"IPv6Gateway": "",
	"MacAddress": "",
	"Networks": {
		"kobofe_kobo-fe-network": {
			"IPAMConfig": {},
			"Links": null,
			"Aliases": [
			"MacAddress": "02:42:c0:a8:c0:02",
			"NetworkID": "5b4d04be69811...",
			"EndpointID": "1c6f3745ead5...",
			"Gateway": "",
			"IPAddress": "",
			"IPPrefixLen": 20,
			"IPv6Gateway": "",
			"GlobalIPv6Address": "",
			"GlobalIPv6PrefixLen": 0,
			"DriverOpts": null,
			"DNSNames": [

so it seems that there’s no binding.

Furthermore, Docker Desktop KPI Container > Logs tab is empty and container after a while dies, with no chances to catch anything relevant.

I also forwarded suggested port (80) for the container, with no success.
I’ve run again the installation process to be sure to choose suggested options.

my wslconfig file sets memory at 8gb and procs at 8, so I hope this isn’t the problem. I have no other services running in docker - except those invoked by

I’ve created a fresh WSL2 ubuntu image; I’ve run apt upgrade on it.

Could someone help me to understand what I’m doing wrong / missing?
Many thanks in advance, have a nice day.