Document has no root element (error message seen in ODK Collect)


Hi. Currently, I am using ODK Collect v1.29.3 and the KoboToolBox server. However, recently I had a problem concerning the forms update. There are some times that I update the forms on ODK Collect and when I try to open a form, the ODK Collect shows this error message: “Document has no root element!”

This error also occured when I used Kobo Collect v1.28.0

Steps to Reproduce

  1. … On the Form Management page, set Blank form update mode as Exactly match server
  2. … Try updating a form several times until you see the error message.

We saw this same error message in all of our current forms and in all of our devices. All of these devices are Android 10.0.0 smartphones which are either Sansumg or LG brands

Have you checked the General Settings>Server>URL? Are they OK? Could you also share with us a screenshot of the same?

Hi, @Kal_Lam

We’ve checked the URL and everything is properly configured.

What has happened is that forms we have been using since the beginning of the last year and that have always worked properly have suddenly begun to present this problem. We haven’t changed anything on the app configuration since then.

We’ve tested our forms on Kobo Collect v1.28.0 also to check if it is a particular problem of the lastest version of ODK Collect, but it had the same bad results, as mentioned by @ricardonfc.

We have noticed the first occurrence of the problem on January 12th, 2021, from when it became recurrent and spread to other many active forms we have. We are asking our enumerators to continue updating the forms until the “form updated successfully” message appears. This is solving the problem for now.

1 Like

Welcome back to the community @nnsdtr! Will give a try to replicate this issue.

Thanks, @Kal_Lam!

Hélène Martin (@LN) from ODK was able to replicate the issue.
You can follow her opinion in the following forum.

1 Like

Thank you @nnsdtr for the updates. The issue should be fixed by v1.29.4.

I am still having the error “document has no root element” when opening forms. They will not open to be filled out.

@saseehav, Do you have both the KoBoCollect android app and the ODK Collect android app both installed in your same device? Id yes, could you remove one of them and see if it works?

I do not have ODK installed anywhere on the device. The android device is a new Samsung Tablet with a fresh installation of KoboCollect 1.29.3. Forms have existed since early 2020 and have gone through a few versions and deployments. The latest deployments in the past month are breaking and won’t open the new forms or send forms

@saseehav, could you share with us the screenshot of the error message you are seeing?

OK, would you mind uninstalling your KoBoCollect android app and trying it with the ODK Collect android app?

yes, will do this. will I use the kobo url and username and password

You could use the same in the ODK Collect android app.

It worked without any problems using the ODK Collect App.

1 Like

Yes, this was a bug in v1.29.3.

What should the solution be? Use ODK Collect until the new Kobo Collect version comes out? The forms won’t submit with these errors.

1 Like

Yes, please. This should solve your issue.