Download data with column NAMES, not LABELS as headers

I am having troubles downloading my data in such a way that the header row contains the short name specified in the “Name” column, and not the longer, explicit question I store in the “Labels” column in my XLSForm.

I have tried to export it with all possible formats (legacy included), as well as with the XML option. However, I always get very long variable names based on the text specified on the “Labels” column.

Would appreciate any hint… Thanks in advance!


You can use for XLS or CSV

1 Like

Thanks for your answer. As I said, I have tried all possible types of exports/downloads, but the result is always the same. In my example, I need the “short_var_name” appear in the downloaded file. But, instead, however I configure the export options, the downloaded file contains the LABEL column (“This is the long name I do not want”).


Downloaded file

The solution adopted so far is to replicate the short names in the Label columns and put the actual questions of the form in the HINTS column, which in terms of formatting the questionnaire does not make sense at all.

I have searched online and did not find anything even close to my problem. So I am not sure if I do not understand a basic fact about the name/label columns…

Thanks again,

It’s possible, we do it regularly. You just need to take the option mentioned above: "XML Values and Headers"

Here a current XLS export example
| HHSample | HHAvailable |
| 1 | 2 |

The XLSForm with the variable names and the labels is
| type | name | label |
| select_one HHSample | HHSample | Is this an Original or a Replacement Household ? |
| select_one YesNo | HHAvailable | Could you CONTACT the Household ? |

This option is also documented in a support article:

Would you mind to provide a screenshot of the setting used for download and the resulting file name (should have …false …, in the file name).


Hello wroos,
Thanks for insisting. After trying once again I exported it correctly.

I cannot understand right now what went wrong all the times I tried before! Sorry for keeping all the repliers busy for a non-existing problem! It is as simple as wroos points out.

Have an excellent day.