Downloading data with labels after changing language

Hi all :slight_smile:

I am experiencing some problems downloading the data with labels.

  1. I noticed that the project did not have language at the beginning, so I changed to English in survey (label::English (en), hint::English (en) and constraint_message::English (en)). Moreover, I changed the choices (label::English (en)).

  2. Then, I tried manually to download the data with the following details

However, the data only has the headers in labels, but the data has the names instead of the labels. I want it with the labels :frowning:

What I have tried:

  1. I tried to download the data in “XLM Values and headers” and then in “English” again, it didn’t work :frowning:
  2. I tried to re-deploy my project and download the data again
  3. I tried to change the language after and before I uploaded the form

Maybe, I follow different steps or I missed some steps. Have you ever experienced something similar?

@StephanieMilan, would you mind sharing with me the following through a private message so that I could have a closer look at it?

  • Username
  • Project name
  • Server

@StephanieMilan, could you share a screenshot of what is not working with the community? I tried downloading your data with labels, and I did not find any issue there?

1 Like

@StephanieMilan, did you mean this with the select_multiple question type? If not, could you share with me a screenshot of the question that has only names instead of the label?

@Kal_Lam, I mean all the headers are ok because they are with the labels, but the content is in code.
Basically, all the columns have this problem. In some cases, it is not noticeable because the name is equal to the label. Here is one example:

So you mean the value code has been displayed as a value label?

Yes, exactly

The value code is displayed instead of the value label

Here is one example with “regular_rain”. This is how I named it in the form (in orange) and the label I want (in green)

It seems like you made multiple deployments to this form editing the choices for the affected variable (question).

I unchecked the Include data from all 9 versions as shown in the image below to see the effect:

… and I could observe that when unchecking the same, the choices get the label:

1 Like

Fantastic! Yes, it works :slight_smile: Thanks a lot

1 Like

@Kal_Lam, I guess there is no other way, right? Because I’ve just realised I need all versions :frowning:

@StephanieMilan, it should be an issue due to the multiple deployments (where you have added the choices in phases).

1 Like

@Kal_Lam, I discovered a new solution: The problem disappears if you redeploy the form but without the language settings. In this case, you should be able to download the data with labels with the following configuration:

Sadly, I need the language to appear as “English (en)” to automatically download it with my Python code.

I was exporting with:

for uid in to_download[‘uids’]:
export=gcsv.create_export(asset=uid, username=username, passwd=passwd, domain=domain, lang=‘English (en)’, type_=‘csv’)

This is because in some cases, the form is in more than one language. I would like to download everything with the default language and if doesn’t exist I want to download it with the language. Do you know how?


@StephanieMilan, would you mind sharing your python snippet so that the community should also be able to help you achieve what you intend?

Thank you @Kal_Lam! :slight_smile:

I solved by:

  1. Adding the language default to the API: _default
  2. Adding an "if " and I didn’t specified the language

For instance:

for uid in to_download[‘uids’]:
if uid == ‘ABC’:
export=gcsv.create_export(asset=uid, username=username, passwd=passwd, domain=domain, type_=‘csv’)
export=gcsv.create_export(asset=uid, username=username, passwd=passwd, domain=domain, lang: 'English (en) ', type_=‘csv’)

1 Like

@StephanieMilan, :clap: :heart: :partying_face:

1 Like