Edit fields not show when download data

Dear All,

We face an issue when we edit data on kobo, We couldn’t found this edit when we download data,
we use humanitarianresponse server

Sorry, could not understand your issue. Could you kindly explain it again maybe backing up with some screenshots?

Hi @slibee
If I understood you correctly, you have edited data on the table view, you saved, and when you downloaded the data in XLS you don’t see the edits you made? If that is the case, could you show screenshots of the process you are undertaking and the difference you are seeing to better explain the problem.

Regards,
Stephane

1 Like

yes, as you said

1 Like

2

1 Like

@slibee, could you share with us the following (through a private message) so that we could have a closer look at your case:

  • Username
  • Project name
  • Server
  • _id for that particular case and the related question

@slibee, could you also kindly share with me the specific _id so that we could identify the issue quickly.

image

Also please let us know the question that holds this issue. It would save our time to verify your issue.

OK, one more question, did you add any options (choices) to the question Gender?

Yes this question is select one (Male , Female)

1 Like

@slibee, I could see that you had missed providing the language code in your survey project. It is good to have language code when you generally have more than one language in your survey project. I updated them as follows:

image

And now you should not have issues with visualization of the labels in your survey project.

Sorry but the issue still not solved

Could you share with me the screenshot on what is now not resolved?

@slibee, seems like I was looking at the other survey project. Will have a look at it again.

@slibee, I went deep into your survey project COVID 19 RESULT and came to know that you had made a total of 9 redeployments. When looking from V1 to V6 you did not have the variable Gender in your survey project. Moving V7 onwards it seems like you added the variable Gender. You will thus have no value for the variable Gender from V1 to V6 if it was collected with the same structure as at that point of time your survey project did not have the variable Gender. However, you should have the value of Gender only for those collections where you collected your data with the structure of V7 onwards.

@Kal_Lam , Thank you for your support,
but if I made a bulk edit and add a gender should this variable take value,
When I made edited it one by one its work but if I do it in bulk it not work.

@slibee, yes it should take values when you try making a bulk edit. But also please be informed that while making a bulk edit you will only be able to edit approximately 500 submissions at a time. At the moment you have more that this figure and if you wish to make an edit with all the submissions it should not work. Hence I would recommend you to make edits in phases (so that you do not try to edit submissions greater than 500 for a single action).

Thank you dear, I will try this solution and let you know

1 Like