Enable to join an audio after recording it

Hello Kobo Community,

Happy new year to everyone!

I wish to ask a question to the Kobo Community because I have a problem while finishing my data collection. My last question is an audio recording, for a testimony. I can record the audio (the audio is now on my phone), but I can’t upload it in the question. An error message appears saying “mime type application / octet stream cannot be inserted into content://media/external/audio/media; expected MIME type under audio/*”. It says the same thing whether I record an audio or I choose an already recorded audio on my phone. Because the question is mandatory, I am enable to finish my interview and thus to send it finalized. All my datas are now impossible to send.

Can someone help?
Thanks in advance!

Welcome to the community @koboML! Do you mean you are able to collect audio question types with Collect android app but are not able to send it to the server?

Thank you for your answer @Kal_Lam. Actually, I am not really able to collect the audio because It doesnt upload in the question. Here the picture attached (sorry its in french… but the error message is in english).

To be able to record an audio, kindly please be informed that your device should have an audio recording app. Generally, android device comes up with an inbuilt audio capturing device. If your device does not have one try downloading a third party android app like RecForge II from the google Play Store. Doing so you should be able to capture audio recording for your survey project for that particular device.

Besides, also please note that you may have to provide access to audio recording for that app. If and incase you do not provide access the app may not work as it should.

Thank you again, but the audio has already been recorded, it is even stored in the phone files. The problem I have here is that the audio file cant be upload in the answer to the question, and thus wont let me “finzalise” my questionnaire because the question is also mandatory

The phone has an audio recording app. I will indeed check the access settings in case… and will let you know!

OK, i just made a quick check with an audio question type. I could record an audio and then also submit the same successfully without any issue using the KoBoCollect android app.

Is it possible for you to share your xlsform with the community so that the community could check the same at their end.

Or as a backup try collecting your audio question in a different device and see if you are able to upload your audio to the server.

Kindly please let us know what happens.

Ok, so I finally managed to finalize my questionnaire by recording a new “empty” audio which worked because I lowered the quality of the audio (from 3gpp to amr) in the audio settings of the phone. It then worked to record a new audio.

But I still couldnt upload the old audio I already had on the phone (which was the actual interview I made), and I still don’t know why. The error message is still the same. I wanted to check on the audio recording access for the app but didnt find anything in Kobo Collect concerning the audio access.

Which format is the audio recording?

Hello @Kal_Lam. Sorry for the late responding. The audio recording was 3gpp on the first place. I then lowered it to “amr” and I could record a new sound.
Does this make sense ?

1 Like

Hi @koboML
I would like to understand a couple of things on your end.

  1. I believe you are using the KoBoCollect application. Could you try using ODK Collect (same settings) and see if you have the same problem?
  2. Has this very form ever worked well for you, if so, when did this problem start appearing on your end?
  3. Have you tried uploading an MP3 format? If not, could you try and tell us what happens.
1 Like

Hello @stephanealoo. Sorry also for the late responding. Actally, this was an issue I saw in the telephone of one of our partner’s organisation data collector. He was indeed using the Kobo App, but as soon as I get back to them (tomorrow), I will download ODK Collect and see if its works. I will then also try to upload it in a MP3 format and will get back to you.

Actually, we are using this questionnaire in a development program data collection, and many of our partners are using it. Some of them are using phones that we bought, and some others are using their own. I believe that this problem happened on one of the phone we bought. Some others had no problem to record and to send. Maybe it was in the phone settings.

Thank you very much for your suggestions,
And I’ll call back tomorrow with latest news


1 Like

Hi @koboML,

Please also be informed that KoBoCollect android app is now available in the play store with the latest version i.e. v1.29.3. Try using the latest version in the device and it should solve the issue you were facing previously. Feel free to reach us back if the issue still persists.