English default language, but KoboCollect/Enketo showing blank forms


I have a form that was initially set-up in English using the form builder on KoboToolbox. French was added as a second language using the excel upload option (English remained the default language). Once French was added, all projects created using the template show an empty form with the default language selected (both in Kobocollect and enketo webforms).

Here is the blank enketo form:

To see the form, English or French must be selected from the ‘Change language’ drop-down menu. However, English is and should be the default language. How can I fix this to ensure English comes up as the default?

Here are the current language settings:

I would appreciate any advice you have!

You seem to have a third “default” language. This can happen if not all referenced columns (labels, messages, media) have been defined with ::language (code) in the survey and choices sheet.

Normally, in the form drop-down you should not have a “default” item, but only your named languages.

If you don’t manage to find the problem, you could share an extract of your XLSform, esp. all column titles of all 3 sheets.

1 Like

Thank you for taking the time to respond.

I thought I had changed all applicable columns. Here are the column titles for the survey and choices tabs. Could you please let me know if these have been done correctly? (I have hidden the contents of the survey as is confidential)

Best wishes

You should also set the ::language for guidance_hint and constraint_message column. and provide a column there for each language. And you may add a default_language column, e.g. English (en) in the settings sheet.
See also Help Center article Adding Another Language to your XLSForm — KoboToolbox documentation and XLSForm documentation XLSForm Docs.

1 Like

Making those changes has fixed the problem. Thank you for your help!

1 Like

@wroos, :clap: :heart: :partying_face: